Zotero stuck in endless updating loop

Hello--I've been working on the citations for a proposal for 3 days now within Google Docs. Today--when I go into add any citations, it gets stuck in an endless updating loop in Google Docs. It goes through the whole document and then starts again. I have to close the tab to interrupt it. I've let it go for 45 minutes and that did not help. Now I'm stuck and cannot finish my proposal.

Any help would be much appreciated! Thank you.
  • edited July 28, 2020
    How are you determining that it's starting again?

    Have you tried restarting Zotero and your browser?

    If you can reproduce this after restarting those things, can you provide Debug IDs from Zotero and the Zotero Connector for a couple loops?
  • Hello--thanks so much for your kind response. What happened was that when I would add a citation, it would start scanning the document. It went on and on. When it would reach the bottom--it would start again. I tried a few things before reverting back to the morning's version of the document. I lost a half-day's work--but it was working again. Very frustrating! Thanks anyway for your help!
  • If you can make a copy of the document and reproduce it using an earlier version of the document from version history, we'd still want to see Debug IDs for it so that we could figure out what was happening and fix it.
  • I can try that if you let me know where to find the Debug information. Once it gets in that loop, I can only interrupt it by closing the tab.
  • I linked to instructions above.
  • I have a historical copy that should generate the error. Before I do that, are we confident that this will NOT affect my main document--which has the same citations/notes as my copy document? The document is at the submission stage and I could land myself in some hot water if something gets messed up with the references page.
  • Yes, the Zotero citations in the copy of a document have no connection to the original.
  • OK here it is while in endless loop mode --> D1811273580
  • I'm not seeing an endless loop here — there's an 80-second delay with no activity before you submitted this. Are you interpreting a spinning progress bar as an endless loop? Because that wouldn't be the case. If you're seeing a progress bar with no seeming progress, it's likely that there's a window behind your other windows. Try cycling through your Zotero or browser windows to see if there's a prompt waiting for your input.
Sign In or Register to comment.