Citations do not update

edited January 22, 2020
I am facing a problem that others here in the forum may have described before, but so far none of the solutions have worked for me.
I am using MS Word 2010 on a Windows 10 computer.
When finishing a long article with more than 250 references I noticed that some of the references are incomplete: eg. ref to journal articles missing the page range. (This is because there were imported into Zotero shortly after publication from Pubmed when the actual entry was still incomplete.)
I reimported them into Zotero, merged old and new entry and made sure the required info is in the entry.
When I then refresh the bibliography (using fields, not bookmarks) the ref (eg. page range) is not updated, worse, when I delelte the bibliography, and reinsert it, the information is still not updated.
A clue to the problem: When I try to insert one of the problematic citations once more into the text, I am given the choice between "cited" (=old and incomple) and "from library" (new and correct). If I chose the second possibility, the reference is added a new ref, so that old an new appear side by side in the ref list. -- How can i make Zotero use only the new merged references and not take them from the text?
(Yes, one workaround would be to delete all 20 or so problematic refs, and resinsert them, however that would be hell, because there are >500 citations in the text, and, using numbers, some of the citations are in number ranges, so i could not search them systematically, could I?)

> For clarity, as the discussion title may be misleading: the difficulty that I am facing is that the bibliography is not updating.
  • So you have gone through ?

    To further clarify, you are missing some information of items in the bibliography that for others is shown? Or is the page range missing for all items in the bibliography (that would then need a modification of the citation style you are using)
  • Thanks for your response!
    There are no duplicates in the zotero library at this point.
    The bibliography in my paper is not updated with the information from the library; zotero uses the "cited in text" citation information instead (these are not being updated).
    The citation style is "Cells" and this seems to be OK; that is page range is shown correctly for all items that were not updated in the way i described above.

  • This sounds like something would have gone wrong with the merge -- e.g. if you deleted the old reference instead of merging. I don't see an alternative to manually replacing the references. You could consider switching to an author-date style to make that easier?
Sign In or Register to comment.