Hanging when adding a citation

This discussion was created from comments split from: very slow loading of Zotero 5.
  • edited 10 days ago
    Hi. I'm having a lot of trouble with slow Zotero too. It is slow to start up, but also, when I try to add a citation, it won't load the library, or does so very slowly. I checked background processes, updated Zotero, unchecked the Automatically add box, re-booted - still a problem. Is there a way to just type in a code for a citation and have it pick up the source on refresh, rather than having to go through the Add Citations dialog box each time?
  • (Best to start a new thread for issues that will require individual debugging. I've moved this here.)

    How many items do you have in your library? Approximately how many citations in your document, and what word processor? Can you provide Debug IDs for 1) Zotero startup, using the "Restart with Logging Enabled…" option, and 2) inserting a citation that causes a hang?
    I tried unchecking the Automatically update box, but now it won't even load the library.
    What do you mean by that? That box has no effect on anything other than whether Zotero tries to update other citations in the document when you insert new citations.
  • Hi - thanks for your help. Right, document is not small. Right now, it's about 125 pages, 155 references in the bibliography, over 300 citations in the text. The library itself has over 4,000 items. I'm using Word version 1902 on Microsoft Office 365 ProPlus subscription. (I think its Word 2016.)

    I edited my earlier question - the question you highlighted above about the Automatic update box. What happened was that after I checked that, Zotero opened an "add citation" screen with the cursor already in an empty folder, so it appeared to hang. Sorry about that.

    Here's the debugging log. D1793358849 For this, it took almost a full 30 seconds to add the citation -- and that was with the Auto update turned off.

    Thanks for your help.
  • OK, thanks — @adomasven will need to look at this to see if the performance is as expected.
  • @pamrooks this isn't the ordinary performance we see from Windows Word, but it seems like the communication between Word and Zotero is slow for whatever reason. How is the speed of this computer otherwise? Are your web browser and Word itself relatively fast? Have you tried restarting the computer? Do you have any security software running? Could you try disabling it temporarily for testing?
  • Thanks -- disabled the security software and it's doing much better!
Sign In or Register to comment.