Sync problem ID 1312692725

Hi everyone,

While trying to sync my library's data from my computer, I get this message
"can't assign to properties of (new String("out of memory")): not an object"
after Zotero stopped running and responding for a few seconds.

I checked if I had any image added in notes, but it isn't the case. Could someone help me on this one ?

Thank you,

Félix
  • How many items do you have in your libraries? Does this happen after restarting your computer, and with no other programs open? If so, can you provide a Debug ID (different from a Report ID) for a sync attempt that triggers this error?
  • I have a total of 104 items in my library. It's still happening after restarting my computer. I have run a Debug report, the Debug ID is D851105958.
    Thanks
    Félix
  • How did you check for images in notes? Have you emptied the trash?
  • I checked my files one by one, and even after emptying my thrash the problem still happens...
  • Try typing <img into the Zotero search bar in All Fields & Tags mode. Does anything come up?
  • I tried and nothing is found.
  • edited 13 days ago
    What's the size of the zotero.sqlite file in your Zotero data directory?

    If you don't mind, can you upload that to the DB Repair Tool and post the Upload ID here? You can ignore the download link the tool provides, but we should be able to tell you from that what's going on.

    (Alternatively we'd need to add some additional logging and have you run a beta build to figure out what item is causing problems here.)
  • My zotero.sqlite file is 5.93 Mo. I've uploaded it ont he DB Repair Tool, with the ID 5ddce15b52896.
    Thank you for your help !
  • OK, this should be fixed in the latest Zotero beta.
  • Ok thank you !
  • Zotero 5.0.78 is out now, so you can switch back to the release version if you prefer.
Sign In or Register to comment.