sync ssl certificate error connecting to

report ID 1927634019
haven't been able to sync for the last 24 hrs due to this error.
Using FF Portable 3.5.1, Z 2.0b6.3
  • The SSL certificate is valid, so this is either a problem with your copy of Firefox or a man-in-the-middle attack. What happens if you browse to normally?
  • edited July 21, 2009
    You're right, I'm in a hotel. Connecting through a proxy worked, local connection must be blocking zotero ssl or something. Other ssl sites and http://* work. Locally going to times out, but through my proxy it's fine. sync'd 17 seconds ago :-)
  • I have just started getting this error too. It began after I changed my account details in zotero preferences.

    When I click I get "Nothing to see here."
  • Uninstalled and re-installed Zotero, which seems to have done the job.
  • I'm getting this error message now. When I browse to I get "Nothing to see here" - uninstalling and re-installing zotero does not help

    ID: 1525119234
  • Are you connecting through a proxy of any sort?

    Have you tried disabling other Firefox extensions?
  • no proxy

    I just disabled all other extensions, but the problem persists
  • It doesn't do it all the time - only sometimes
  • You're probably going to need to find some pattern, if there is one. That error really should only occur if the connection is in fact insecure. It's possible it could be triggered by network problems that interrupted the SSL handshake, but that's just a guess—that could explain the intermittent nature, though.

    You can enable debug logging from the Advanced pane of the Zotero prefs, get it to occur, submit the output, and post the Debug ID here, but I'm not sure how much we'll be able to tell from it. If you go that route, keep the Advanced pane open and clear the debug output before each sync, and then submit it as soon as you hit the error.
  • Hello

    I have the same problem when I try to sync
    ID : 708879279
    I've got also "nothing to sse there" when i browse to
  • Same problem here. No proxy in use. This just started happening. Going to, I get not error messages or prompts to accept the certificate.

    Report ID 559592313

    I do not believe that this is an issue with other extensions since a colleaque of mine has the same problem and apart from Zotero, there is no extension that we both would have.
  • Just started happening when?
  • I noticed it 30 mins ago. The last time I synced was approximately 24h before that and that went through without any problems.
  • Does it happen every time? Does it happen if you restart Firefox?
  • Restarting firefox fixed the issue.
  • I found this error when trying to sync for the first time on my work computer. The issue was due to security settings required by my work. By clicking on I was initially asked to accept a certificate; I added it and now do not get the SSL error anymore.
  • Just a word of warning for others: whitelisting SSL certificates is a very bad idea, unless you know for a fact that a site uses a self-signed certificate, which is not the case with Zotero.

    labontea: A network configuration that triggers a warning on all SSL certificates seems highly problematic, since it means there's no way for you to guarantee that the connection is indeed secure (and that, for example, you're not actually connected to some other site masquerading as
  • @Dan Stillman: thanks for the information and input. Do you have any advice for handling this diplomatically with my network config people? It seems to be their strategy for anything having to do with FireFox... I am forced to use IE for many things because of it.
  • Without knowing specifics of the setup I can't really comment, but it's certainly not good security for users on the network. (It's possible that they're doing it on purpose to allow them to intercept secure communications—which is one of the things SSL is designed to protect against—but it could also just be misconfiguration.)
  • Report ID: 1834697250
    I don't know whether it is advisable to start a new thread or add to this old one (by way of demonstrating a good faith effort to figure things out without bothering you), but I'm stuck. I approved the exception for, and the (failed) sync merely lasted longer this time, but still no completion. Yes, I have restarted Firefox multiple times; I don't have any other extensions. The files are not that large, so that shouldn't be the problem. I reinstalled Zotero a week or so ago for other reasons, and have rechecked all the sync settings to make sure they are correct: same problem before and after. I'm using an ADSL connection at home, but if the provider is the problem, then what should I tell them?
  • I approved the exception for
    Do not do this. As I said above, this is a very bad idea, and we're not going to provide support for people who have done so.
  • OK, exception removed. And the initial problem still stands: no syncing, despite having double-checked all the settings.
  • If you're getting the SSL error in Zotero, and you see an SSL warning when you browse to, there's a major problem with either your Firefox installation or your network.
  • Report ID: 920291752
    Reinstalled Firefox. Browsing to yields "Nothing to see here" (and no SSL warning). The error report speaks of " : potentially vulnerable to CVE-2009-3555." If that's not diagnosable at your end, then this is what I need to take to my (Hungarian speaking!) network? The despair becomes palpable...
  • Unexpected status code 0 caching authentication credentials
    This is the relevant error you're getting now. We've never reproduced it ourselves and don't know what causes it. My best guess is that it has to do with interrupted connections (which could also cause spurious SSL errors). If this is a laptop, try syncing from a different network. Otherwise, try disabling other Firefox extensions and any security/firewall software you have on your computer.
  • And restart your computer, certainly, if you haven't yet.
  • OK, thanks (yes, this is a laptop). Although the syncing error remains, it is not (as it was when I first tried this some time ago) entirely preventing my database from uploading to the library. There does not seem to be anything missing on the face of it (though I will continue backing up by other means), so it's close to achieving the desired purpose.
  • This is a file sync error. It doesn't affect data syncing.
  • (Though, yes, an SSL error connecting to would affect data syncing.)
  • Hi,
    I am also getting the following error..while trying to Sync with zotero server.

    "SSL certificate error connecting to" - Report ID: 678081866

    I have got a new laptop from my office and after installing firefox and zotero in my laptop...I cant sync to zotero anymore...

    Is it the problem of zotero, firefox or is it for some kind of security imposed by the local network I am using...

    Thanks for your reply in advance....
Sign In or Register to comment.