New Item(s) Button and Updates Not Working

edited July 11, 2019
I am having a number of issues with Zotero. I wanted to use the "add items using identifier" button and it worked a few times and then it just stopped working. I need to restart it to add something to my library. I also think the updates stopped. The current version is 5.0.55. I am on a Mac. I just signed up for the larger storage option thinking it would fix my problem, but no that would be too easy. lol. I have a big conference coming up and would love to use Zotero to take notes.

Report ID: 307255942

  • I also get a request to install a helper when I open the application. I can enter my system password or press cancel and then there is another message about how I need to check to see if there are multiple versions of Zotero on this computer. How do I check for that?
  • Have you tried updating manually? You should be on version 5.0.69
    That might fix things.
  • Thanks. How can I do that? I did not see an option on the zotero website.
  • edited July 11, 2019
    I have selected "Check for Updates" and a window opens up that says downloading Zotero, and "connecting to update server" but nothing happens. I only waited like a minute or two. But this time I'll just leave it open to see if anything happens.
  • Updating shouldn't take more than a few seconds, so you can just restart if it's not doing anything, and the update will likely go through at that point.

    If you're still having trouble after upgrading, we'd want to see a Debug ID for an Add Item by Identifier attempt that fails.
  • The update is not working. Nothing happens. Please advise.
  • edited July 15, 2019
    When opening the application I get two messages. The first one is to enter my password for the computer the other is a software update error that says, "The update could not be installed. Please make sure there are no other copies of Zotero running on your computer, and then restart Zotero to try again." How do I do this? Also, when I open the application it shows up someplace else on the dock, and so I remove it from the dock when I reopen it.
Sign In or Register to comment.