Zotero Not Working on Linux

Hi , Apologies if there's already a discussion on this and I missed it. I just downloaded Zotero on my Chromebook with Linux. The application opens correctly. When I hover over or click on things like File, Edit, Tools, Help, etc. drop down menus will appear.

But clicking on any of the options in the drop down menus or shortcut icons does nothing. I can't even open settings or About Zotero to see what version it is, etc. I've restarted and that didn't change anything.

Any ideas?
  • Is this a Chromebook running a full linux distro or Chrome OS with linux apps running? If the former, which distro? How did you install Zotero?
  • Honestly, I'm an amateur at this. But I'm pretty sure this is Chrome OS w/linux apps running. (The only reason I've gone down this path is b/c I need a citation manager for grad school and android apps I've found are not as robust as Zotero desktop.)

    Here are the steps I've followed:

    1. I went into my Chrome OS settings and turned Linux Beta on. This downloaded a terminal. 2. I then downloaded the Zotero Linux file from: https://www.zotero.org/download/
    3. I used an app for Android to extract the Zotero file that was downloaded and copied it into my Linux file folder
    4. I asked for help on a Chromebook forum how to actually install the extracted file and someone told me what to type into the terminal: 'sudo apt-get install zotero-standalone'
    5. The app installed and appeared in my launcher. But that's as far as I've gotten.
  • Yes, 4. is the problem. That's not the way to install the downloaded app, that's just installing a (significantly outdated) version from a repository.

    Instead, try this:
    First, run
    sudo apt-get purge zotero-standalone
    to completely remove the old Zotero.

    Then install as described here: https://github.com/retorquere/zotero-deb (I'd use the curl version -- I know for sure curl would be included in ChromeOS's linux shell)

    There are some additional steps you'll need for the browser integration to work as ChromeOS runs Linux apps in a separate segment ("sandbox"). There's a thread on this that you should be able to find here on the forums.
  • Okay, thanks. Definitely getting closer. I tried the curl and it started to install, but ran into this at the end. And Zotero didn't show up in launcher.

    Import process completed.
    Done
    done.
    Errors were encountered while processing:
    makedev
    z8530-utils2
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    After this, I tried the wget and ran into errors too, but accidentally closed terminal without screenshot and so I don't have the error message.


  • @emilianoeheyns -- any ideas on the above? Do you offer the .deb for download somewhere? Couldn't find it.
  • The debs can be found at https://github.com/retorquere/zotero-deb/releases/tag/apt-get

    The errors shown above would be indicative of a previous .deb install gone wrong (my Zotero packages don't pull these in); you could try to do

    $ sudo apt-get -f install

    $ sudo apt --reinstall makedev z8530-utils2

    before trying to install Zotero again.
  • edited 26 days ago
    You don't need to use the install shell script BTW, all it does is


    # get the GPG key
    curl --silent -L https://github.com/retorquere/zotero-deb/releases/download/apt-get/deb.gpg.key | sudo apt-key add -

    # add a apt repo
    cat << EOF | sudo tee /etc/apt/sources.list.d/zotero.list
    deb https://github.com/retorquere/zotero-deb/releases/download/apt-get/ ./
    EOF


    Doing those by hand would yield the same results.
  • (but if I'm reading that output right, those commands from install.sh completed successfully and would not need to be repeated)
  • Okay, thanks so much. I don't want to keep pestering with questions and I really appreciate your time. Just one last thing as the lines above ran into problems too.

    Here's what I got for sudo apt-get -f install:
    dpkg: dependence problems prevent configuration of z8530-utils2:
    z8530-utils epends on makedeve (>=2.3.1-22); however:
    Package makedeve is not configured yet.

    sudo apt --reinstall
    E: Command line option --reinstall is not understood in combination with the other options.

    If there indeed was a problem with previous installation (likely caused by user error?) would it be worth:

    1. Trying to reset Chromebook and reinstall Linux and start over?
    2. Or should I have done the purge command line before doing the sudo apt-get -f install?
  • It's makedev, not makedeve
  • Wait, it's pulled in as a dependency?
  • What happens if you say

    $ apt-get -s remove makedev z8530-utils2

    $ dpkg -l | grep ^..r
  • For apt-get -s remove makedev z8530-utils2 it says:

    NOTE: This is only a simulation!
    apt-get needs root privileges for real execution
    Keep also in mind that locking is deactivated,
    so don't depend on the relevance to the real current situation!
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required
    libdbus-glib-1-2 libnspr4 libnspr4-dev libnss3 libnss3-dev
    Use 'apt remove' to remove them,
    The following packages will be REMOVED:
    makedev z8530-utils2
    2 not fully installed or removed
    Remv z8530-utils2 [3.0-1-8+b1]
    Remv makedev [2.3.1-93]

    For dpkg -1 | grep ^. .r it says:
    dpkg: error: unknown option -1
  • For the 2nd command it's -l (letter ell) not -1 (number one).

    try


    $ sudo apt-get remove makedev z8530-utils2 libdbus-glib-1-2 libnspr4 libnspr4-dev libnss3 libnss3-dev
    $ sudo apt-get purge zotero # if this does nothing or complains, that's OK
    $ sudo apt-get -f install # if this does nothing or complains, that's OK
    $ sudo apt-get update
    $ sudo apt-get install zotero
  • Okay, I got a Zotero icon in my launcher, but when I click there's a spinning white circle and it doesn't open.

    To clarify for:

    sudo apt-get purge zotero #

    I need to actually just put the hash sign, right? Or should I have put Zotero 5.0?
  • The # starts a comment, you don't have to type if but the shell will ignore whatever is after it.

    What happens if you start /usr/lib/zotero/zotero?
    What is in the file /usr/share/applications/zotero.desktop?
  • /usr/lib/zotero/zotero
    XPCOMGlueLoad error for file /usr/lib/zotero/libxul.so:
    libdbus-glib-1.so.2: cannot open shared object file: No such file
    or directory
    Couldn't load XPCOM.

    /usr/share/applications/zotero.desktop
    -bash: /usr/share/applications/zotero.desktop: Permission denied
  • edited 25 days ago
    Strange, according to https://forums.zotero.org/discussion/comment/332104#Comment_332104 libdbus-glib-1-2 was no longer required

    try

    $ sudo apt-get install libdbus-glib-1-2

    and then try to start Zotero again.
  • It worked!! Many, many, many thanks!! I really appreciate you sticking with it to get me to the end.
  • What ChromeOS version are you on? I can (re)add libdbus-glib-1-2 to the deb dependencies and they'd be pulled in automatically but I'd rather not pull in more dependencies than required.
  • @adamsmith do you know what FF version Zotero for Linux is built from?
  • Thanks -- I've changed the build process so the package takes the existing dependencies from firefox ESR (which includes libdbus-glib-1-2 at this moment).
  • @emilianoeheyns This machine is running Chrome OS 74. (It's a Dell Inspiron Chromebook if that makes any difference.)
  • It shouldn't, but that means that lib is still a required dependency on ChromeOS 74. In any case, the new debs have it (and some others) as gleaned from the firefox ESR dependencies. Should just work now.
Sign In or Register to comment.