Zotero not working with Mac Microsoft Word

Report ID: 215678378

I am running Zotero 5.0.66 and Microsoft Word for Mac version 16.25, Mac OS Mojave 10.14.4.

None of my previous documents which I have used Zotero as the citation manager are displaying appropriately. Instead, it is showing field codes in the text of the documents (starting with "ADDIN ZOTERO_ITEM CSL_CITATION" and then details of the citation).

This is true for documents I have been working on, as well as all of the previous documents that have worked fine for years that I still have saved. Zotero and Mac were working fine until a few days ago - I think there was an update to Zotero that I installed at that time.

I also tried opening a new document in word to insert a citation and I get this error message "Zotero experienced an error updating your document." When I try to add in a new citation, I have the Zotero toolbar appearing in Microsoft Word, it gives me the redbar popup to search for the citation, but will not insert it or display it properly.

I have tried restarting Word and Zotero multiple times, and have tried reinstalling the Microsoft Word Add-in. The Zotero add-ins for Microsoft Word and LIbreOffice integration are both enabled in Zotero. I am running both programs as the same user. I really don't know what to do next.
  • great thanks. This worked to fix the problem.

    It doesn't make any sense to me that fixing the field codes also helps to fix the "error updating your document." the troubleshooting pages did not bring me to the field codes page, so I spent hours working on this myself before posting in the forum. Perhaps make it more clear on the Field Code troubleshooting page what error messages will appear.
  • It wouldn't normally. I'd guess that was a coincidence in this case.
Sign In or Register to comment.