ID 2012184060


I have troubles with the word processor plugin. I am running it on Word 2010 (Win7). Zotero version is the last updated, the add-ons is enabled and I have reintalled from the Cite -> Text processors tab. I have checked and follow every posibility described in the troubleshooter but still not getting it to work.
Actually, for some reason I have two files in the "extensions" folder, the .dot and the .dotm, one of it seems damaged (appears with an "!") Anyways, the complement shows in Word but it is just unresponsive (I can click on it but nothing happens). I think the .dot or .dotm file might be corrupt, can I download that file alone and copy it in both the "extensions" folder from Zotero and the "start" folder from Word?
Thank you in advance,

  • Start by deleting both of those files, and then restart Word and make sure the Zotero plugin is gone from Word. Then close Word and reinstall from the Cite pane and see what happens.
  • If you think the file is corrupt, somehow, you can reinstall Zotero before reinstalling the plugin — the file comes from the installation files (as explained in the manual installation instructions, but those shouldn't be necessary if the file is appearing properly in the Startup folder).
  • Ok, so now I deleted both files, from both folders (the "extensions" folder from Zotero and the "start" folder from Word). Restarted Word and the plugin is gone.

    Now, when reinstalling from the Cite pane an error messagge appears: "Installation could not be completed. Make sure that Word is closed and restart Zotero". Word is closed, I restarted Zotero but still the same error appears.

    Thank you again!
  • edited April 18, 2019
    OK, so now try the manual installation instructions. (There's a good chance this is due to security software.)
  • "2. In the installation folder, open extensions\\install, where you you can find a copy of the file Zotero.dotm (for Word for Windows 2007 and higher) or (for older versions of Word)."

    Ok, so as you told me, I removed the .dotm file before. This folder is now empty (and the error when trying to reinstall it from the Cite pane still pops).
  • edited April 18, 2019
    Ok, so I realised there are two folders for Word ("Startup" and "Inicio"), as I use it in Spanish. I have empty both of them now, and I have selected the "Startup" one as default from the "options" menu in Word. I don't know if this can be a source of problem.

    Anyways, I tried to reinstall from the Cite pane in Zotero but the error still shows.
  • Right, but I'm saying to follow the manually installation instructions now, to put the file there manually, since something (probably security software) is preventing Zotero from being able to do it automatically.
  • The extensions\\instal folder is emty, there is no .dot or .dotm file so I can't do step 2 from the manually installation.
  • That means your security software is deleting it. Reinstall Zotero. If it keeps being empty, you'll have to figure out what on your system is doing this.
  • Ok, seems to work properly now. Thanks a lot for the help!
Sign In or Register to comment.