paste not working from right mouse click

Hi there...

Zotero is fantastic. Just wanted to say that... I've been using Zotero for almost a year, it's great. I have a Windows XP computer with Word 2007.

When copying text from a web page, I highlight it, choose copy from the mouse menu and then choose to "add note" from Zotero. Then I click in the "add note" pane... I right click and get nothing... I then have to CNTL V to paste the clip.

I do most of my work with the mouse, so using a keyboard shortcut is not ideal.

I've tried different programs, and right click paste works. I've tried different mice... no squeak.

I also downloaded the Firefox 3.5 addon Extended Copy Menu 1.6 which allows for Copy, Copy Plain Text, and Copy HTML... no joy there either.

Am I doing something wrong, or is this a bug/feature?

Thanks so much,



  • Context menu support currently doesn't work in the rich-text notes in Zotero 2.0. But you can add a note by selecting text on a web page and choosing "Create Zotero Item and Note from Selection" or, if a note is already selected, "Add Selection to Zotero Note".
  • Thanks Dan...

    I'm not sure what Add Selection to Zotero Note means... If I have a blank note open... which I do by clicking "add",
    then what process or click works "Add Selection to Zotero note"

    On a related note... did Zotero "paste" work previously ... I'm now using 2.beta...


  • Thanks Dan... Nothing like getting help from the lead developer....

    Maybe I'm missing something here... is Tiny MCE already installed in Zotero... or do I need to download and install it...

  • It's already included in Zotero 2.0.
  • Thanks Sean...

    Before we lose sight of my issue... which is Paste not working from the Right mouse click... The Tiny MCE site also seemed to have an issue with Paste... it may be another type of problem... as Copy and Paste works fine in Word for me... it could be that the issue is not with Zotero or TinyMCE but with Firefox... as it seemed that the issue came up with the new release of Firefox... now that Firefox is out of Beta... maybe that is the place to find the solution...


  • It's unrelated. You'll need to use Ctrl-V until context menu support is fixed.
  • Thanks Dan...

    I may look into getting a mouse with some "mappable" buttons...

    Thanks again for Zotero... When I wrote a presentation for new students at Western Governors University ... I definitely included a big plug for Zotero ... fantastic!

  • Thanks Dan for the new beta update...

    I'm sure that whatever you are doing is correct... I may be doing something wrong myself or not explaining my issue clearly...

    The copy/paste function in ZOTERO is not working from the right mouse click... during the ADD NOTE process... it works in WORD... even works here in the forum... here is a copy and paste from the new change log ... it is just not working in ZOTERO.

    Rich-text note improvements

    Upgraded TinyMCE to 3.2.5
    Added paste plugin to fix messy pastes from Word
    Added context menu plugin to allow copy/paste via mouse

    Thanks for the terrific response to this minor issue...

  • Could you explain the exact steps you're taking and what's happening (or not happening, as the case may be)? Pasting via context menu should work fine in 2.0b6.2, and does for me in OS X and Windows XP.
  • Hi Dan...

    I am using Win-xp-pro fully updated. It's on an older 64bit laptop with 1.5 gigs of RAM. I'm not quite that old. I'm using WORD 2007, Firefox 3.5 and the latest Zotero. I'm writing online college papers, maybe 30 references per paper and probably 25 or 30 collections.

    When I have a web page open. I have Zotero open. I highlight a passage. Right-mouse click to open context menu - I choose copy. Under the Zotero panel "Notes" I left click the "Add" button which opens the Add Note sub-panel which shows the "Title" in the top section and the Rich Text toolbar. I left mouse click in the white panel.

    At this point I usually click inside the white panel to bring up the mouse context menu.
    It does not open.

    I control- v to "paste" my text in the panel.

    In writing this message I've noted a possible workaround. If I choose the " (quote) icon on the Rich text menu I can then I can click the icon. Right click the " that appears in the pane which is then replaced when I choose "paste" from the Mouse context menu.

    Maybe this is a new "rich text" feature, but it's messing with 15 years of mousing...
    It could also be some computer "speed" issue. If I keep clicking or "Enter" I eventually get a Mouse context menu ... but it highlights the previous passage keeping me from adding to the sentence in the Note.

    This only happens in this sequence... not in Word or other programs.

    I'm sure all of this is too much idiocracy, but that's what happens when you have to work with the general public, like me.

    Thanks so much...

  • OK, I think I'm seeing the issues you're referring to.

    First, just to clarify, the rich-text note field in Zotero isn't a standard text field, which is why it's not acting like one. It's using TinyMCE, a JavaScript-based rich-text editor that tries to emulate a native rich-text word processor. Until Firefox provides an adequate native rich-text editor, we have to make do with JavaScript workarounds like TinyMCE and any limitations they have.

    Anyhow, the first problem, I believe, is that you're just clicking too low in the field. The TinyMCE context-menu plugin that we enabled in 2.0b6 appears to only register right-clicks when you click on a line that already contains text, not in empty whitespace below. This is obviously contrary to how right-click works in standard text fields on any OS, but it's the way TinyMCE works at the moment.

    A bigger problem is that it looks like the context-menu plugin doesn't work as well on XP as it does on OS X. Right-clicking the end of a line on XP does appear to highlight the enter line, which pretty seriously hampers the ability to use the context menu. This isn't specific to Zotero—I can reproduce it on XP on the example on TinyMCE's site. It looks like this only happens when you click to the right of the end of the line, so a workaround is to hit the spacebar a few times and then click in the space you just created, and then paste.

    Unfortunately this isn't our code and isn't something we're likely to take the time to fix ourselves (particularly since pasting via Ctrl/Cmd-V works just fine), but with any luck these are issues that the TinyMCE folks will fix in a later version, which we'll happily integrate into Zotero.

    Hopefully the workarounds above will help. Otherwise, you may want to just use Ctrl-V until the TinyMCE bugs are fixed.
  • Thanks Dan...

    Good explanation...

    Hopefully Firefox or TinyMCE will update their code ...

    Thanks again...

  • A little more info ... kinda off topic...

    I used to have a Contour Shuttle Pro... which had 15 programmable buttons... but it quit working after a flood... and I haven't replaced it yet... I also use a 32 inch monitor to help see the text... so workarounds are nothing new... if I had known how much time I'd spend in front of a computer I would'a paid more attention in typewriter class... (I know, I know, what's a typewriter?)

    Thanks again...

  • Hi there...

    One more thing I've noticed, under Zotero-Actions-Preferences-Keyboard shortcuts- there is a command - Import from Clipboard
    (which I think was a request from another user)

    It uses Cntl-Alt-V as the command... I know it's not Cntl-V.

    Could this have something to do with the issue?

  • edited July 12, 2009
    Could this have something to do with the issue?
    I'm not sure what issue you're referring to, but no, it's not related.

    Import from Clipboard runs the standard file import process (for BibTeX, RIS, etc.) on data on the clipboard. It doesn't have anything to do with pasting.
Sign In or Register to comment.