Report ID: 1996016000 "The range cannot be deleted"


This error obtains when I try to add a prefix to a citation and sometimes when citing a page range. It is unclear why sometimes a page range raises the error, and sometimes it does not.

"Track Changes" is off.

I'm using Chicago full-note, but it also occurs in other citation styles.

Thank you for your help!

  • If you're still having trouble but this works in a new document, see Debugging Broken Documents.
  • Thanks for the link. I've perused that page and tried the suggestions. But my problem still persists -- it does not work in either a new document or an old one.
  • You're saying this happens in a brand new document (not copying and pasting from the old document)?

    If so, can you provide Steps to Reproduce the problem in a new document?
  • It was happening so intermittently, I couldn't tell where the problem was introduced. But I found a reproducible instance.

    Steps to reproduce:

    1. Start Zotero
    2. Start Microsoft Word with Zotero Plugin
    3. Create new document
    4. Zotero plugin: Add/Edit Citation
    5. Choose Chicago Manual of Style (full-note)
    6. Choose two sources, include a page number
    7. Select footnote just created, click Add/Edit Citation
    8. Place the cursor between the two citations and add another source.

    Raises error: "The range cannot be deleted."
  • What version of Word are you running? Have you tried updating?
  • Office 2010
    Version: 14.0.7228.5001 (32-bit)

    No updates seem to be available.
Sign In or Register to comment.