Google Docs: "We're sorry, a server error occurred. Please wait a bit and try again."

edited 5 days ago
Hello,
I'm using Zotero (version 5.0.59) in a Google Doc to insert citations. It was working fine. But now, I can't insert new citations. The error message is :
"Zotero a rencontré une erreur lors de la mise à jour de votre document.
Exception: We're sorry, a server error occurred. Please wait a bit and try again."
The error ID is : 220245836.
Thanks
  • Has it started working again? If not, is it only broken in one specific document or do no documents work?
  • Not yet. It's only broken in this specific document. I reinstalled Zotero and the connector, but it's still broken.
  • edited 6 days ago
    I am having the same problem. Though I understand that the Google Doc integration is just out of Beta(ish), the problem is there seems to be no way to diagnose this problem. The error message is useless. How can I identify the problem?

    In my case I have removed all Zotero citations and bibliography from the Google Doc and it still gives the same error. However, creating a duplicate of the document re-links Zotero and seems to allow new citations to be added.

    Unlinking citations in the original document fails.

    I have created a debug log. The Debug ID is D663445921. This was attempting re-add the deleted bibliography containing one item (from the one citation I have left in the document). This worked two days ago when the document citations were first test converted to Zotero citations.

    This is a large collaborative document, so the biggest problem is, right now I cannot freeze the document, make a copy, delete all citations and bib, and rebuild without disrupting the collaborative editing.
  • We are also affected by this problem.
    https://i.imgur.com/Th8ZUBj.png

    I submitted a new error report and a started a new discussion with the Report ID (but it's not published yet).
  • @Valio: Could you provide a Debug ID (different from a Report ID) for triggering this error?
  • @dstillman Thanks for the follow-up.
    The Debug ID I got is D1632322537
  • @eejd Do you have comments in the original document? When you make a copy of the document, does it make a difference whether you include those or not?
  • edited 5 days ago
    @adomasven There were comments in the original document. I have also migrated to FireFox to use the Beta Connector to ensure latest bugfixes. (Original error was in Chrome.) The same error occurs.

    I made two new copies.

    Copy without comments now returns:

    "Selected field EMxrXl not returned from Docs backend"

    The Debug ID is D939868287.

    Copy with comments returns:

    "Exception: We're sorry, a server error occurred. Please wait a bit and try again."

    The Debug ID is D2101325313.
  • Could you use the step 8 of debugging broken documents instructions on the copy of the document that still returns the "We're sorry, a server error occurred" error to cut it down to a small example that will still produce the error and then share that document with support@zotero.org?
Sign In or Register to comment.