latex errors at 'keyboard character undefined'


I have been using zotero to build a library of sources and I like it. There is one problem I am having, however: I export my library to bibtex and when running my document with latex, I get the error:

! Package inputenc Error: Keyboard character used is undefined
(inputenc) in inputencoding `latin1'.

See the inputenc package documentation for explanation.
Type H <return> for immediate help.

l.113 \newblock 1997, p. 101

The question-mark is, in the bibtex file, a long dash. If I replace this long dash with two short dashes, I no longer have a problem. This is annoying, however, to have to do every time I export my library.

Anyone know a solution that will tell zotero to stop producing this long dash?

  • If your BibTeX tools don't support UTF-8, enable "Display character encoding option on export" in the Advanced pane of the Zotero prefs and select ISO-8859-1 as the character set on export.
  • Ah, great. Thanks for telling me the fix.

Sign In or Register to comment.