extracting annotations w/zotfile works BUT the link does not connect me to the location on pdf

hello there, so after I have highlighted on Preview (in mac) and I extract annotations, when I click on the icon in the extracted annotation that says "open link" to take me back to the quote, it merely opens the pdf but does not send me directly to the actual quote. I've tried this with several pdfs and all with the same result. I am using zotero 5 ... thank you for your help.
  • What version of Zotero and ZotFile? If you click on the link in the note and choose "Insert/edit link", what is the underlying zotero:// link for one that doesn't work?
  • zotero 5.0.58 and downloaded the latest zotfile from the zotfile site and this is how the link looks as an example: zotero://open-pdf/library/items/IQ8SJDFP?page=60
  • There are new security restrictions in macOS Mojave that are still very poorly implemented by Apple. When you first did this after upgrading to Mojave, you would've been prompted to allow "System Events" to control your computer, and you would've had to have followed confusing instructions to allow access in System Preferences. Currently, it doesn't prompt again, so if you miss it the first time there's no indication of why it's not working after that.

    To fix it, go to System Preferences → Security & Privacy → Privacy → Accessibility, make sure the lock in the bottom-left is unlocked, and then check the checkbox for System Events. It should work again after that.
  • omg it worked! thank you!
  • edited November 14, 2019
    Hello! I´m having the same issue, sadly the solution didn´t work for me...

    Mojave latest update. Latest version of Zotero and Zotfile. Zotero and System Events are checked in Acessibility, but when I click a link (extracted table of contents, anotations) it only opens the pdf, not the right quoted page.

    Any ideas? Thanks in advance for your help.
  • Btw, I already tried to delete Zotero and System events from Accessibility, forced to ask again to allow "System Events" to control my computer, checked that they are included again in Accessibility, and checked that the links include the right page number... Still no luck.

    Any comment wil be appreciated!

    Thanks in avance.
  • Hello,

    I´ve created this report ID 166206100, but there´s no error message and the "report errors" window tells me that no errors have been found.

    Mojave latest update. Latest version of Zotero and Zotfile.

    My main issue is the same described in the first post: "when I click on the icon in the extracted annotation that says "open link" to take me back to the quote, it merely opens the pdf but does not send me directly to the actual quote. I've tried this with several pdfs and all with the same result."

    It happens with any link, in extracted table of contents from a pdf or annotations. The link seems to be ok and include the right page (i.e. zotero://open-pdf/0_P5H8KLZV/198), but it only opens the pdf first page, and not the right page in the link.

    The first time I tried this it asked me to allow "System Events" to control my machine. I clicked YES and in System Preferences → Security & Privacy → Privacy → Accessibility I checked the permisions for Zotero and System Events to control my computer. But I can make a link to open the page that is supposed to open.

    Thank you!
  • What PDF reader?
  • I´ve tried with Preview and PDF Expert (as default reader in Preferences), the same thing happens. If I select Adobe Reader in Preferences, Zotero keeps using Preview instead.
  • Can you provide a Debug ID (different from a Report ID) for clicking one of these links?
  • Yes, of course. ID D709120420, I opened Zotero, clicked on a link to a pdf´s chapter in a table of contents, and the pdf´s first page opened. Then I sent the report.

    Thanks for your help!
  • (3)(+0000710): Running /usr/bin/osascript '-e' 'tell app "Preview" to activate' '-e' 'tell app "System Events" to keystroke "g" using {option down, command down}' '-e' 'tell app "System Events" to keystroke "231"' '-e' 'tell app "System Events" to keystroke return'
    Ah, is this a non-English system? If you open a PDF in Preview and click the Go menu (or equivalent), what is the keyboard shortcut for "Go to Page…" (or equivalent). Something other than Cmd-Option-G, I'm guessing?
  • Thanks for your reply!!

    Yes, this is a spanish system, but the shortcut for "Go to page" is the same, cmd-option-G...

    Nonetheless, thanks to your appeciation, I´ve noticed that there is a problem in my system. When I´m in Preview and I press the "Go to page" shortcut, it doesn´t work right. I checked with the keyboard viewer, and seems like my system doesn´t recognize the three keys shortcut the way it should:

    - If I press cmd-option-g, the g is not recognized in the keyboard viewer.
    - If I press g-cmd-option, the g is recognized and the shorcut works just fine.
    - If I press fn-cmd-option-g, the g is recognized, and the shorcut works.

    Besides, if I start the system in Safe Mode, there is no error, the g is recognized, the shortcut works just fine and the links in Zotero are working too. So, I think it has to be some trouble with something installed in my system...

    I just tried almost averything that ocurred to me: reseting all preferences in the keyboard menu, checking that there are no conflict between system shorcuts, trashing keyboard and trackpad preferences, changing the language for the system and the keyboard to English, cleaning the Pram, using Onyx to maintenance an cleaning... But still no luck.

    Bright side is that I managed to make the links in Zotero to work, just holding the Fn key before clicking. That way Preview recognizes the "Go to page" shortcut and takes me to the right page.

    I think I´ll try to figure out what is going wrong, but for now I have a way to make it work.

    Thanks a lot dstillman for your comments and interest.
Sign In or Register to comment.