EXPORT. OVERLEAF Invalid format of field 'urldate'

edited 8 days ago
I have been using my Zotero bibliography in Overleaf for quite some time with no problems what so ever.

Until I started getting several messages of error like this one in Overleaf:

./main.bbl:
Package biblatex Warning: Biber reported the following issues
(biblatex) with 'appelgren_data_2014':
(biblatex) - Invalid format of field 'urldate'.


I have no idea how to fix it. I've tried to change the 'date' reference for some of the references directly on Zotero (from 'mdy' to 'y'). It seems to have worked, but it is a lot of trouble to do that with all the references. Besides, I don't want to lose this kind of information from Zotero.

Advices?
  • urldate is the accessed date, not the regular date in Zotero. Best I can tell, that's exporting correctly in the form YYYY-MM-DD to biblatex, both form the client and via API (which is where Overleaf gets it). Are you able to see the .bib file Overleaf is trying to use when compiling. And you have overleaf selected to use biblatex/biber, right?
  • Opened the .bib file. All urldates had 'TZ' in the end, like this {2018-09-14TZ}. Do you know why? Anyways, just deleted the .bib file and sync again with zotero. It worked. Thank you.
  • I have no idea why that would have happened, sorry. It's nowhere in the code. Either a glitch in the Zotero API or a glitch in Overleaf's sync with it. Don't think we'll be able to tell unless this happens again, which it hopefully won't.
Sign In or Register to comment.