ZotFile rename breaks file attachments.

Hi guys, help would be greatly appreciated here.

I'm a new Zotero user, and when I saw that Zotero only offers 300MB of storage, I decided to find ways to have my PDFs somewhere else. In the end, I settled on using ZotFile to rename attachments to another folder (Google Drive).

My process was:
1. Change ZotFile Location of Files preferences to my Google Drive folder.
2. Change Zotero Files and Folders preferences' Linked Attachment Base Directory to said folder.
3. Manage Attachments > Rename Attachments in context menu. Can confirm that the PDFs are actually moved from storage to said folder.
4. Here's where the problem is. When I try to view the PDF in Zotero, it says "The attached file could not be found."
5. I downloaded Zutilo and when I show the attachment path, it gives me "storage:file.pdf". Googling around, I've tried to modify the attachment path from storage: to attachments:, but nothing works, it's still the same.

I saved them to Zotero using the chrome extension, if that's any help.

I've also noticed that when PDFs are saved in the Zotero storage folder (before renaming with ZotFile), they're in a subfolder with a random string of characters, whereas in the ZotFile folder I specified, the PDFs are saved directly in the root directory.

What am I doing wrong, and what is the fix? Thank you.
  • This does sound like a ZotFile bug. Which operating system, which Zotero version, which Zotfile version? And this happens every time you rename/move a file using ZotFile?
  • Zotero 5.0.53, ZotFile 5.0.8.

    I don't think it's OS specific, as I'm using Zotero both on Ubuntu 18.04 and Windows 10. It's the same problem.

    Anything I can do to reset everything? I don't mind losing all my items for now.
Sign In or Register to comment.