Footnote Anchors when migrating from LibreOffice to Word

Hi there,

This has been a little bit of a problem for a while now, but I never let it really bother me. Still, now I'm in the last few months before I have to hand up my PhD dissertation, and so, well, yeah.

I use LibreOffice for my writing, and save my documents in odt format. But my supervisors insist on using Word, and thus need it in either doc or docx. I know I'm supposed to be able to use the "Bookmarks" option under Document Preferences to help with this problem, but that option is always greyed out, and unavailable. I've had to stick with the "Fields" option. Now, that's not too much of a problem, because I don't need to CHANGE the citations once their in Word format. I just need them to migrate over neatly and effectively.

The problem is, most, if not all the citations come over from the odt to the docx, with the Footnote anchor NOT in superscript. Often it's the same for the Footnote characters in the citations themselves.

Given I have hundreds of citations in each chapter, and thus may well have over a thousand by the time I'm done, the idea of manually changing them all to superscript is not an attractive prospect.

Anybody have any ideas how to solve this problem?
  • The Bookmarks option is greyed out because LibreOffice does not support bookmarks in footnotes or endnotes.

    The anchor is also something LibreOffice sets, not Zotero -- when you insert a Chicago citation, Zotero effectively tells LibreOffice "insert a footnote here". So solving this is unfortunately not something Zotero can do. That said, I've found LibreOffice's .doc implementation significantly better than it's .docx, so you may want to try that.
  • You might also try asking your supervisors to open an ODT in Word. I’ve found Word’s support for odt to work well.
Sign In or Register to comment.