Zotero experienced an error updating your document.

Hi - this is the error message when trying to insert a citation - any idea what I can do to remedy please??

"Zotero experienced an error updating your document.

this.registry.citationreg.citationById[c[0]] is undefined"
  • What version of Zotero are you using?

    Try to delete the bibliography at the end of your document and re-insert it.
  • @adomasven @fbennett -- seeing a fair amount of these & similar errirs in the last couple of days. They look more like a potential citeproc issue than a problem with the add-on; any ideas on this? Adomas, have you seen any samples from documents that may help with this?
  • edited March 18, 2018
    We'll need steps to reproduce the error to determine the exact cause. Nothing has changed in citeproc-js recently in that area, although that doesn't necessarily mean that the processor code is not at fault.

    Certainly citeproc-js could raise a more meaningful error message there. I'm currently working on some unrelated changes in the processor to address a bug in Juris-M abbreviation support. When that's done, I'll include code to handle the error and offer what information we can to assist @adomasven in debugging.

    (What's happening there is that the processor is being called with a pointer to a citationID that has not yet been registered.)
  • edited March 19, 2018
    @adamsmith we likely have some corner-case bugs in the updated integration code. One has been fixed in the latest beta.

    @fbennett more verbose citeproc errors would be very useful

    @ambermarieknows please install the Zotero beta version and see if you still get the issue. If you do, please submit a Report ID and then follow step 8 of debugging broken documents instructions and email the broken snippet to support@zotero.org with a link to this thread.
  • Hi team - that seems to have fixed it - thankyou so much!!!!
  • I think I spoke too soon....
  • Zotero experienced an error updating your document.

    The operation couldn't be completed. (OSStatus error -1708.) @[selectField:field.m:341]

    Getting this error. My references are again repeated like this
    [10] [10] [10] [10] etc,
    I tried refreshing, everytime one more number is added to the lines. Help!!!
    I thought I had debbugged my paper few days back. I have not inserted any new references, just rearranged text in couple places.
  • edited March 20, 2018
    @adomasven citeproc-js v1.1.196 should provide some details to help pinpoint where in the document the two errors that are cropping up are being thrown.

    (Edit: unfortunately the error above is not coming from the processor, but it should help with others.)
  • @adomasven Make that citeproc-js v1.1.197 (slight improvement in the details thrown)
  • I changed the reference style, then I closed both zotero and word; reopened, changed back the reference style to the original one and turned autoupdate preference in zotero (I had it off and was doing refresh periodically). Then I manually deleted the references that had strings of numbers in them. It seems to have worked. I hope. THANKS for all your work on zotero
Sign In or Register to comment.