Error: "The update could not be installed"

When I start Zotero 5 for Mac standalone, (with Zotfile 5 also installed), it does two strange things. First, it immediately starts a second copy, so now the icon is showing twice in the toolbar. Second, it gives me a popup with the message "The update could not be installed. Please make sure there are no other copies of Zotero running on your computer, and then restart Zotero to try again", and *simultaneously* another popup asking me to authorise an update (which I do). It does not say whether Zotero or Zotfile is being updated. When I quit, only one of the copies goes away. I have to force quit the other one.

I have tried restarting Zotero, with the same result.

I have tried re-installing the latest versions of both Zotero and Zotfile by hand from scratch. The problem then goes away for a while, but re-occurs later (presumably at the next software update).

Any ideas how to fix this?
  • I'm having the same issue.
  • Delete Zotero from /Applications, delete /Users/:username:/Library/Caches/Zotero/updates (which you can access by holding down Option and selected Library from the Finder's Go menu), and then reinstall Zotero from zotero.org.
  • edited 10 days ago
    I have a dual boot windows-ubuntu box. I'm getting this problem with the current update from 5.0.60 to 5.0.62. However, my windows boot (where the problem occurs) does not have the locations in your post: /Applications, /Users/:username:/Library/Caches/Zotero/updates. How to fix the problem that I cannot install this update, please? My system also hangs connecting to the Update Server, what to do? Report ID: 27236872
  • @psod: Those are Mac file locations. On Windows, the equivalent would be uninstalling Zotero via Windows, deleting C:\Users\[User]\AppData\Local\Zotero\Zotero\Zotero\updates, and then reinstalling.
Sign In or Register to comment.