Slow response from Word Plugin

Since the 5.07.SA.5.0.34 Word for Windows Integration add-on was installed on 13 Jan, I have noticed that several functions in MS Word appear slower than usual.

In a 2 page document with 5 references clicking:
document preferences: 6 sec (previously 2?)
new citation: 5 sec (previously 1?)
edit citation: variably 1-5 sec (previously 1?)
Insert bibliography: variably 1-5 sec (previously 2?)

I say "variably" for the latter two functions because while it was giving me issues earlier, they now seem to have sped up again. This may be an intermittent issue?

Zotero 5.0.34
Zotero Word for Windows integration 5.07.SA.5.0.34
MS Word 2013 (15.0.4997.1000) 32-bit.

Thanks for a great program.
  • Sorry for the delay in responding.

    If you're still having trouble, here are two files for you to try:

    https://download.zotero.org/tmp/2018-01-30-winword/a/Zotero.dotm
    https://download.zotero.org/tmp/2018-01-30-winword/b/Zotero.dotm

    Can you save those to disk and then copy each one into your Word startup folder separately and see if there's a clear difference in speed between the two? (There may not be, but this will help us narrow down the problem.)

    Instructions for finding your Word startup folder are here:

    https://www.zotero.org/support/word_processor_plugin_manual_installation#locating_your_word_startup_folder

    (It's probably just the default location listed at the bottom. There should be an existing Zotero.dotm file there that you can overwrite.)

    You'll need to restart Word after copying each file to test it.
  • Hi,

    I have the same issue, and the first file is working in my computer on MS Word 2017. Now the add-on works well and it takes just 1 sec to appear.

    I also download the second version of the file, and it is as quick as the first file.

    I don't know why, but it works better.

    Now, should I delete the original file from the Startup file?

    Thank you,

    Nicolas, Lyon, France
  • @dstillman
    Both these files work great. I get the impression that the second one works slightly faster but the difference (if present) is negligible.

    Thanks for the quick response.

    A.
  • In case this is still relevant:
    - I had similar problems as discussed above, but way worse (didn't time it, but was very variable, estimating anywhere between 5 and 25 seconds)
    this is much better with the versions above, with a being significantly better than b.

    cheers!

    d
  • @Dani_Bodor: Are you seeing that reliably, though? As in, if you switch to 'a', does it reliably become slow, and if you switch to 'b', does it become fast, regardless of how many times you go back and forth? The sense I've gotten is that the speed has been extremely variable for the people reporting this, so it may be easy to perceive variations between the files that are really just caused by restarting Word and trying again.
  • edited February 9, 2018
    The same problem as mentioned by the topic starter occured to my Zotero-plugin since a few days. The fix as mentioned above did help only for some minutes, after that, Zotero reacted very slow again. I tried both a and b of the files above, there is no difference between the two. Can you help me with another fix?

    Zotero 5.0.34
    MS Word 2010 (14.0.7192.5000) 32 bits
  • haven't switched back and forth extensively.
    What I have seen is that before I replaced the original file with either a or b, it was extremely slow, as mentioned.
    Both a and b made it much much faster. When I did this, a seemed noticeably slower than b, but both fast enough not to be frustrated by.
    Slightly off-topic, I do notice that the first time I want to add a citation to a document in any particular session (i.e. after opening the doc) it is rather slow. it's fine from the second time on, though.
Sign In or Register to comment.