Zotero crashes when dragging items from local library to group library

Zotero crashes when dragging items from local library to group library. Errors 1100132971 and 1864300316.
  • edited May 15, 2009
    This issue is similar to Mryckman's. It is limited to certain items.

    These first two work fine:
    Croft, William, and Keith T. Poole. 2008. Inferring universals from grammatical variation: Multidimensional scaling for typological analysis. Theoretical Linguistics 34, no. 1: 1-37.

    Asante, David. 1886. Eine Reise nach Salaga und Obooso. Mitteilungen aus den Geographische Gesellschaft zu Jena 4: 15-40.

    While this one produces a crash:
    Christaller, J. G. 1888. Die Volta-Sprachen-Gruppe, drei altbekannte und zwei Neubekannte Negersprachen vergleichend besprochen. Zeitschrift für Afrikanische Sprachen 1: 161-188.

    But I can see no significant differences between them.
  • However, sometimes it also has to do with the sheer number of items. Dragging one item to a new group library worked; dragging 500 resulted in a crash.
  • Haven't been able to get this to work after the first reference was successfully dragged.
    Zotero 2.0b3.4999 Ubuntu Jaunty Firefox 3.010
    report id. 1385310674
    I've sent the debug report too.
    Regards, Jon.
  • edited May 15, 2009
    Also, Zotero is doing way too much work here. FF locks down for a full 20 seconds after dragging three items from a collection to a group library. I'll have to avoid it until the bugs are ironed out...
  • edited May 15, 2009
    Could it be related to when the item was added?
    I just added

    Walker, Chris. 1993. Karl Jaspers as a Kantian psychopathologist, I The philosophical origins of the concept of form and content. History of Psychiatry 4, no. 14 (January 1): 209-238. doi:10.1177/0957154X9300401403.
    ———. 1994. Karl Jaspers as a Kantian psychopathologist, III. The concept of form in Georg Simmel's social theory: a comparison with Jaspers. History of Psychiatry 5, no. 17 (March 1): 037-70. doi:10.1177/0957154X9400501703.

    With no problem at all. They were both added within the last week. Whereas

    Walker, C. 1993. Karl Jaspers as a Kantian psychopathologist, II: The concept of form and content in Jaspers' psychopathology. History of Psychiatry 4, no. 15: 321.

    i.e. same author, will not copy without crashing Firefox and was added almost a year ago.
    Regards, Jon.

    Noticed that the one that didn't copy was Walker C., not Walker Chris so changed the C. to a Chris and lo it now copies into my Group folder. So it's date modified then?
  • Yeah... I was running into this stuff here:


    The conclusion I came to was that either in early versions of zotero, or in earlier import methods used by zotero, item creators were getting null values for a few fields in the db that shouldn't be null. Near as I can tell, that's now causing a problem.

    If I had to guess, it's because the creator record is duplicated when you add an item from your library into a group library. The duplicated record is then given the libraryID of the new library - this helps keep your personal library separate from the group library. Anyway, I wouldn't be surprised if there's some constraint that prevents the null values from being put into new records, so when it tries to duplicate the old records, it hits a snag.

    Fortunately, if that's correct, it's probably a really simple fix. You could just run an sql statement that gets rid of those null values and everything should work.

    I haven't tested this at all because I don't want to screw anything up with my account and I'll just wait for the developers to work it out for real... But that's kinda what I think is happening.

  • edited May 15, 2009
    Could it be related to when the item was added?
    Jon, I thought that too for a minute but adding the oldest references in my library (Nov 2007) didn't crash it.
  • Thanks Mike. Perhaps the db repair tool could be tweaked to fix this? For those of us too chicken to start running sql statements on our databases.
    Regards, Jon.
  • Well... it's still possible that it has something to do with the timing or an import. For example, maybe they never had those fields in 2007... maybe they were only impacted when you imported the items... maybe there was just a bug in one version and whatever you added at that time was impacted.

    If you want to check, just make a copy of your sqlite file and open it with an editor, you can figure out what the creators look like on the items that work and the items that don't.

    Here's a shot of my data...


    Any of the items with the creators with the NULL entries for shortName and birthYear don't work.

  • Incidentally, I'm not positive it's the NULL entries... that's just the only obvious thing I've found. All of my items that work don't have the NULL entries, and all that don't do have those entries. I joined zotero in October 2008, and it was right at the end of october that they released a major update to zotero. Some 700/900 creator records in my database have the NULL values, and all of those 700 were added before the end of October. But I can't say if that's because of the import I did to migrate to zotoro, or if it's from something else...
  • I see. Certainly your NULL is the most likely candidate then. I hope they'll get to it soon.
  • I think I've found one solution to this problem. I took an item which caused a crash when dragging to a group library, and I exported it to RDF. I then deleted it from my library, and imported it again. I can now move the item to my group library with no problems at all.

    I have a pretty big library, so I don't know how practical this would be on a large scale. However, a lot of my stuff has been through a few version updates, so this export/import approach might be the best way to ensure the 'health' of my collection.
  • Yeah... I wouldn't be surprised if the import process now sets those values the way they should be set.

    Still, it's looking like a simple enough fix... and if so, I'll just wait for the developers to patch it myself...
  • I have the same issues. I'm using Mac OSX 10.5.7, FF 3.0.10. I thought that Zotero might be crashing while in the middle of a sync, so I waiting until that was finished and tried again. I was able to create a folder in the group library (which I wasn't able to do before) but Zotero continues to crash when I try to move items from my library into the group folder. I, too, will wait for a fix on this one. I'm excited to start sharing my work with the group.
  • That was the key, Mike. I opened up my Zotero database (e.g. 'zotero/zotero.sqlite') with a SQLite editor (SQLite Browser -- http://sqlitebrowser.sourceforge.net/ -- in my case), and ran these two SQL statements:
    update creatorData set shortname = '' where creatorData.shortname is null;
    update creatorData set birthYear = '' where birthYear is null;
    That seems to have fixed my problem (reported earlier -- http://forums.zotero.org/discussion/7001/error-after-moving-an-item-to-a-group-923226175/ -- on a separate thread).
  • Thanks for the suggestion. Made a copy of my squlite file and ran the SQL statements. That does seem to have fixed it. It is incredibly slow though - took about four or five minutes to move 30 references from a folder.
    Unfortunately am now getting the "Error processing uploaded data" problem, so my online library isn't updating in any case, sigh.
  • Yes -- I see the same error message. I can't imagine that the SQL statements messed things up, but I kept a backup copy of my database just in case...
  • No I don't think so either - enough people have been having this problem that I suspect it's something else. Wait and see ...
  • Hi,

    Similar problem to what has been described above. Using latest version of Zotero (2.0b2) with Firefox 3.0.10 on windows XP Pro SP3 machine. Zotero Library contains ~10,000 records.

    Problem - dragging item from "My Library" to collection resulted in the wait cursor appearing. Firefox remained unresponsive for about 5 minutes eventually resulting in a message:--
    Warning: Unresponsive script
    A script on this page may be busy, or it may have stopped responding. you can stop the script now, or you can continue to see if the script will complete.

    Script: chrome://zotero/content/xpcom/data/items.js:53
    An option of "Stop Script" and "Continue" was provided -- I chose the latter, at which time the library came back online.

    I then tried dragging the item from that collection to another collection. Firefox remained unresponsive for about 5 minutes then eventually came back on line. No error box appeared.

    I submitted the error log: The Report ID is 672936378.

    These 'delays' or 'lagging' did not appear in version 1 or 1.5.

  • edited May 17, 2009
    This error is now fixed on the trunk, and the fix will be included in the next beta build, which should be out within the next couple days. The SQL statements mentioned by dltj above are a fairly safe workaround in the meantime, if you know what you're doing. Thanks to mryckman for the very helpful diagnosis.

    A delay with dragging would be a separate issue, and we'll look into that.
  • Let's take the drag delay discussion to another thread.
  • Fixed in 2.0b4, now available.
  • Awesome. Thanks for the fix! :-)
  • Wheee! Works beautifully. Thanks.
  • Worked fine. Thank you.
Sign In or Register to comment.