PDF files cannot be grabbed by Zotero from IEEE Xplore

edited November 20, 2017
The IEEE Xplore has just been upgraded these days. The extension of zotero in chrome can not grab the pdf files from IEEExplore. My chrome version is 62.0.3202.94 and my zotero version is 5.0.27. The URLs of the files are:
and many other files I have tried is not available either.
Thanks a lot if any solutions can be provided!
  • Is there any solution?
  • This works for me. Are these the URLs exactly as you see them when you click the Save to Zotero button? Does PDF import from other pages work?
  • When I click the save to zotero button, the abstract or information of the paper can be fetched except the PDF file. I have tried other pages in IEEE exploer, it cannt work either. But in other sites, it works.
  • And these are the URLs exactly as you see them, right? You didn't remove anything inserted by you university? And when you click on the PDF icon, the PDF opens, correct? Do you see Zotero attempting to download a PDF -- it shows up in the "Saving to Zotero..." pop-up and then gets a red x -- or not?

    When you hover over the Save to Zotero button with your mouse, what does it say?
  • It works now. Maybe there's something wrong with the server. Anyway, thanks a lot!
Sign In or Register to comment.