WebDav verification error and pdf attachments

In June I received a WebDav verification error and red symbol at the top right of the Zotero pane. I am running Zotero 4 for Firefox on a Win 7 system and connecting to a cloud server (CloudMe) through WebDav. I had previously ignored the WebDav verification message in Zotero sync menu which said it could not verify the server because no red symbol appeared. Despite this message Zotero worked just fine until June. The only way I could get WebDav to verify a connection to the cloud was to change the name of my Zotero cloud directory from upper case "Zotero" to lower case "zotero". When I used the "show file" menu for any pdf in my cloud directory Zotero could not find them. I suspect the reason for this is that Zotero was trying to find the original upper case "Zotero" directory through a link attached to the bibliographic data record. I have about 4000 pdfs attached to data records. I have just returned from a couple of months absence and have not placed any new data records or pdfs into Zotero since renaming the cloud directory. Are the links the source of my problem and if so is there a way to repair them?

Many Thanks,
Graham
  • I'm not really following. The folder Zotero creates and looks for on your WebDAV server is 'zotero'. Linked files don't sync. If a stored file isn't available, see Files Not Syncing.
  • OK. I guess I did not explain things well. Zotero cannot find pdf attachments from the `show file`menu. The pdfs are present on my cloud drive and WebDav is set up correctly to access that cloud drive. I opened the `storage`directory on my computer A and examined many of the storage directories under the Firefox default profile but could not find any pdfs. I thought the pdfs were stored here and assume that is where Zotero looks for these attachment files. I am running Zotero 4 on computer A and Zotero 5 on computer B and I am syncing automatically between the two computers. Also, I routinely used Zotfile to move pdfs to the cloud drive. Maybe this information points to a problem?
  • If you're actually referring to WebDAV syncing, the linked page has instructions on how to debug this and how to provide more information if necessary.

    I'm not sure what you mean by this, though:
    Also, I routinely used Zotfile to move pdfs to the cloud drive.
    ZotFile generally deals with linked files, and Zotero doesn't sync linked files, so if those are what you're referring (indicated by a chain link in the attachment icon), it wouldn't be a syncing issue. If those are showing as missing, the files just aren't in the location where they were previously and where Zotero is looking for them. Folders within 'storage' would indeed appear empty for linked files, since the only files there (for full-text indexing, etc.) would be hidden by default.
  • OK. I now see that the icon for attachment files has changed to a chain link. If I understand correctly, then this is not a syncing issue which makes sense. Given that computer A and B cannot find these files, how do I proceed to get Zotero to discover these attachments?
  • I'd check out the Zutilo add-on to figure out where specific links are pointing. https://addons.mozilla.org/en-US/firefox/addon/zutilo-utility-for-zotero/

    To move linked files from Computer A to computer B, you'd use some other syncing app like Dropbox.
  • Here is the problem: the link directs Zotero to look in "X:\Documents\Zotero" (upper case Zotero folder). The new file path is "G:\Documents\zotero" (lower case zotero). The change of drive letter X to G was due to upgrading Netdrive. What is the best way to edit all these links?
  • edited 13 days ago
    You can change them in bulk with Zutilo.

    After fixing them, you'll want to set the Linked Attachment Base Directory in the Advanced → Files and Folders pane of the Zotero preferences to that location. That will change them all to relative paths so that if the directory changes in the future all you'll need to do is update the base directory setting to point to the new location. (You can also have a different base directory on different computers if you have access to the network drive from different computers.)
  • I tried various modifications of the file attachment path but no success locating the exact pdf. When a "show file" in the Zotero menu I cannot locate the pdf. When I opt for the "Locate" option I can find the directory with all the pdfs in there (NOT links but actual pdfs). The paths I have tried using in the attachment file links through Zutilo are "G:/Documents/zotero" and "G:/" and "G:" (G is the cloud drive - CloudMe service - set up through WebDav and verified in Zotero). All modifications to the attachment links listed above give me the zotero folder but not the exact pdf. I set the base directory in the advanced option in Zotero preferences to "G:" (relative paths). I am using the Firefox version of Zotero 4 and doing all testing on this version. I guess there must be something else that needs modifying?
  • It sounds like you're not using Zutilo correctly. What exactly are you doing there? It works effectively like search&replace
  • Thanks. Yes, I appreciate how Zutilo works. The bottom line is that I can locate the base directory but not the actual pdf through the modified link. The syntax I see in the Zutilo statement for the link is: " G:/Documents/zotero/title.pdf" and this accesses my custom base directory which is set to "G:". The cloud drive name on computer A is "CloudMe (G:)" and this is stripped to "G:" when I choose this as the base directory. I must be missing a step somewhere?
  • If you do Help -> Debug Output Logging -> Restart with Logging Enabled, you can see the path that Zotero is trying to use when you try to open a file.
  • OK. The output is:

    (2)(+0000001): Attachment file 'G:\G:\Documents\zotero\Adam_Green_2010_Trace element partitioning between mica- and amphibole-bearing garnet.pdf' not found

    (2)(+0002030): Attachment file 'G:\G:\Documents\zotero\Adam_Green_2010_Trace element partitioning between mica- and amphibole-bearing garnet.pdf' not found

    As you can see the drive designation is repeated. This is not shown in Zutilo - there is only one G: designation. Could this be due to my designating a custom base directory as "G:"?
  • I don't know the specifics of what Zutilo does, but just unset the base directory until you have this resolved.
  • The base directory was previously blank until I designated drive "G:". Iy is not clear how to delete the "G:" designation and get back to the original blank.
  • "Revert to Absolute Paths…"
  • OK. When I did this Zutilo was able to show the doublet drive "G:/G:/" which I modified to single G. I tried to find a pdf using absolute paths and Zotero was looking in the Storage folder under Mozilla (no pdfs here). Then I went back to relative paths using cloud drive G: but with no luck. Zotero verified the WebDav connection to the cloud drive. With a relative path set to G: I sent a Debug report ID D1237531211 to the Zotero website. Perhaps you could take a look and give further advice.
  • Invalid persistent descriptor -- trying relative

    Attachment file 'C:\Users\Graham\AppData\Roaming\Mozilla\Firefox\Profiles\03tbm4p8.default\zotero\storage\G:\Documents\zotero\Abbou-Kebir et al_2011_Origin of spinel-free dunite veins from northern Oman ophiolite2.pdf' not found
    Since you're editing these outside of Zotero, this isn't something I can help you with, but I'd strongly suggest forgetting about the base directory setting and WebDAV for now and just getting the files to open. And at this point you might want to consider reverting to a backup of your database and trying again, since it's not at all clear the state of the paths now, and simply changing a drive letter should be a trivial change.
  • edited 9 days ago
    OK. I reverted to a backup version of my Zotero database that has simple links to attachment files that previously worked. I have been using Netdrive3 to create a local drive G: and I am trying to connect to pdfs stored on the Cloudme site through WebDav settings in Zotero. I have tried 2 versions of Netdrive with identical results. The links can open the zotero folder on Cloudme where I can see all my pdfs but Zotero cannot locate the exact pdf using the "show file" menu item. I can open the pdfs in a pdf reader. The WebDav link is verified by Zotero. And so I do not think the problem is Netdrive or Zotero but likely lies with Cloudme. Unfortunately, there does not appear to be any tech support and the Cloudme forum is barely active.

    And so I would like to transfer attachment files to another cloud service like Dropbox or Box. Is this just a matter of copying the attachment file "zotero" folder containing the pdfs to another site and modifying the links in the Zotero database library using Zutilo? How should I make this transfer?
  • I think you're misunderstanding this. Linked attachments have nothing to do with Zotero's WebDAV syncing. Zotero doesn't sync linked attachments. They're accessed as absolute file paths on your own machine, or relative paths if you use the base directory setting. If the current absolute path doesn't match the current location, you can fix that with Zutilo or convert them to relative paths with the base directory setting and then change the base directory to point to their current location. Zutilo makes it a bit easier to see what's happening.
  • edited 7 days ago
    Progress has been made. I figured out that the old file path to attachments in the cloud drive has changed to a simple root directory, in my case "G:\".. This new configuration was either done by Cloudme or Netdrive. An absolute file path now serves to access all attachments in the cloud drive from the Zotero data directory. The attachment files are now synced outside of Zotero via cloud drive syncing. I edited all the links using Zutilo. Many thanks for making me aware of this utility. All this editing was done on Computer A which is runnung Zotero 4 for Firefox. My second computer B is running Zotero 5.

    When editing my Zotero database links I previously turned off syncing. I have also made a backup of the current edited database. When I turn on syncing in Zotero preferences will all the new edited links overwrite those stored on the zotero server? And can I then sync with computer B?
  • OK, if you have the links working via absolute paths on one computer, that's when you'd want to set a Linked Attachment Base Directory. Then you sync, and set the Linked Attachment Base Directory to the equivalent location on another computer.

    (If they're accessible at the same path on both computers it's technically not necessary to use a base directory — assuming Zutilo is setting the paths properly to cause the updated items to sync — but if they're all in the same location a base directory is a good idea, since it'll avoid problems like this in the future if you move them somewhere else. E.g., you could move them to Dropbox and just change the base directory.)
  • And to be clear, you'd leave WebDAV syncing off, or at least not pointing to that same folder on the WebDAV server.
  • edited 7 days ago
    OK, Zotero seems to be working correctly after syncing and resolving conflicts by specifying to use the local database on computer A (although Firefox crashed Zotero continued to sync the database). Since I am using Zotero 5 on computer B, as soon as I invoke Zotero it will try to sync files automatically with WEbDav enabled and trying to synchronize the links. In Firefox I could access the Zotero preferences to make these changes. How do I proceed to sync computer B and turn off WevDav/set the base attachment directory prior to syncing? I also assume that if I need to deal with conflict resolutions I need to overwrite the local directory on Computer B?
  • Maybe I could simply uninstall Zotero 5 on Computer B and then reinstall it to rebuild my Library with the new links?
  • Just open Zotero with your internet connection disabled and change the sync settings.
  • Just sync. There’s no need to set the base directory before syncing.
  • Gentlemen, A sincere thanks for all your help and patience. I am now up and running on both computers. Sure is nice to have Zotero back!!
Sign In or Register to comment.