Zotero developer helpd to fix my website error! Not recognizing unAPI? Something else?

edited 11 days ago
ADDENDUM: This thread began when I reported a problem with Zotero not recognizing items for import from my website. Dan Stillman looked into the issue and identified a problem that developed on my website that kept Zotero from recognizing records for import. The problem on my SafetyLit site was resolved and Zotero now is able to import journal articles' metadata again. I've revised this post to show that not only is Zotero wonderful but they are able to help resolve problems even when the fault lies elsewhere. With my sincere thanks, David


Connector debug: D901698288

[EDIT: In general, Zotero is able to recognize the record type and download the metadata from most publishers and database sites. However, I'm having problems with my site although it worked fine as recently as last week.]

To my knowledge nothing has changed on my website SafetyLit.org but after my most recent connector update (I'm using 5.0.8-beta.11+b3b9cac07; connector 5.0.17) I am no longer able to have Zotero recognize individual items from any record, for example:

https://www.safetylit.org/citations/index.php?fuseaction=citations.viewdetails&citationIds[]=citjournalarticle_556581_36

https://www.safetylit.org/citations/index.php?fuseaction=citations.viewdetails&citationIds[]=citjournalarticle_556761_22

or grouped items:

https://www.safetylit.org/citations/index.php?fuseaction=citations.summaries&op2=AND&week=1501387200&classification=catagory_wise&categories[]=22

For individual items a get save as a webpage. For grouped items Zotero recognizes that there are multiple entries and presents a folder icon but a click on it displays an error box "An error occurred while saving this item. See Troubleshooting Translator Issues for more information."

I am using Firefox 54.0.1 (64-bit) [The connector debug ID is for that attempt] but I have a similar problem with Chrome Version 60.0.3112.90 (Official Build) (64-bit).

[EDIT: I just downloaded the Safari connector and tested it with the same failing results. ]

Zotero used to recognize SafetyLit items by unAPI. SafetyLit also provides embedded metadata in several formats in the page headers. In the past Zotero preferentially brought in unAPI formatted material but a right-click offered other options. Now, none of the metadata options are shown by a right-click.

I hate it and find it annoying when I read other posters' comments that "this works from Mendeley, why not with Zotero?". However, that is the case here. I know that Zotero was able to recognize SafetyLit items early last week because I demonstrated this to a class. I was able to get metadata and abstract via Zotero at that time. Today I cannot get either when using Zotero but both metadata and abstracts are imported into Mendeley. Mendeley doesn't recognize multiple listings on a page.

My questions: Is this a new problem with Zotero or the newer versions of the connector? If not please look into this issue and let me know if there is something I must change on the SafetyLit server to get this to work again. I do have access to an old machine that has the Zotero 4.x Firefox plug-in installed. Would it be helpful for me to drag that out and test there?

Thanks

Sign In or Register to comment.