Error message in Zotero 5.0

Hello, I am currently having difficulties syncing my articles with my group members as a message saying "A sync operation is still in progress" keeps popping up whenever I click on the sync button. Please advise.

Thank you,
Eleanor.
  • Can you provide a Report ID to start?
  • Hi, the report ID is 735585021. Thanks for your help.
  • We'll try to figure out how this happened, but have you tried just restarting Zotero?
  • I have tried restarting Zotero a couple of times, but the same error keeps popping up whenever I try to sync it.

    Thank you.
  • Ah, OK, that's helpful, actually. Can you provide a Debug ID (different from a Report ID) from Zotero startup using the "Enable after restart" option for a sync attempt (or two) that produces this message?
  • So click on the "Enable after restart" button prior to restarting Zotero? After restarting, then I should be getting a debug ID? Thanks.
  • That's right.
  • Hi, the debug ID I received is: D998093147. Thanks.
  • OK, try the latest beta and let me know if that helps. (We'll push these changes out as a 5.0.1 later today if you were planning to switch back to the release version.)
  • Hi, my apologies for not responding previously. I have upgraded to the newest version, and there does not seem to be a problem anymore. Thank you.
  • Hi, currently the number of files in my standalone zotero app (29 182 files) and online server (42 000+ files) does not tally with each other. I have synced it over the past few days, with no error messages so far.

    Your help is greatly appreciated. Thank you.
  • edited 9 days ago
    Has it finished synced? What does it say when you hover over the sync icon?

    If the sync has stopped, can you provide another Debug ID for a sync attempt that completes without error?
  • Hi, thanks for getting back. For some reason, it does not stop syncing whenever Zotero is on. It currently says 'Downloading items in AAI meta analysis'.
  • edited 9 days ago
    Yeah, that's quite likely what it's doing. This library (with child items) is extremely big — several times the size of the largest libraries that could be synced with 4.0 — and may take quite a while at the moment to finish (but, unlike 4.0, it should actually finish). If you expand all items (as explained in that linked page) and deselect everything (click on an item and then Cmd-click to deselect it) you'll hopefully see the count in the right-hand pane going up.
  • (Obviously we hope to speed up initial syncing, but once it finishes the first time subsequent syncs should be basically instantaneous.)
  • Hi, may I clarify what "the middle column" means under the tab you directed me to?
    My group mates, whose zotero show the correct amount of files, are suggesting to me to reinstall the zotero app. Do you reckon this would help? Thanks.
  • edited 9 days ago
    The middle pane of Zotero, where the items list is.

    No, don't reinstall — it won't help, and clearing your data and starting again would only make things much worse.
  • Hi, my apologies. I am unable to find a column that says "items list". Under the AAI Group Library in my stand-alone zotero app, I can only see "title" on the right, and "creator" on the left. Thanks for your help, I won't reinstall then.
  • It's just referring to the middle section of the Zotero window, where your items are. When no items are selected, Zotero shows a count in the right-hand pane, so if you press + to expand all parent items, you'll see a count of the total items in your library.
Sign In or Register to comment.