Can't copy attachments to group library

  • In one of the anwers above, adamsmith states that

    "a) Attached files are not transferred where the group doesn't allow attachments or where you don't have the required permission to add/edit files"

    I am the creator and owner/administrator of a group and want to make some of the collections from My Library available in the group library. I tried the drag-and-drop method and sure enough, the collections in question from My Library were indeed copied. However, none of the (many) attachments were copied. What did I do wrong?
  • have you tried manually adding an attachment on an item in the group?
  • edited May 19, 2017
    Yes, by drag-and-drop as I usually do in My Library. Nothing happens. For testing, I removed one of the collections in the Group library and dropped a new copy of the same collection from My Library in its place. Still no attachments were copied. I am now resyncing and will see in a minute or two if things have changed for the better.
  • That's not what I'm asking, though. When you select an item in the group library, can you attach a file using the paperclip icon (or right-click --> add Attachment)? If not, you likely don't have file sharing enabled for that group.
  • No, I cannot. The "Attach Stored Copy of File..." button is greyed out. I have found no way to change file sharing options for a group. Is there a button somewhere that I have missed?
  • It's online under group settings.
  • And note that you can't share files in a public, open group.
  • Sorry, I must be stupid or partly blind (or both). I see (and can modify):

    - Group name
    - Description
    - Disciplines
    - Upload a new picture
    - Group URL
    - Enable comments
    - Group type (it is set to Public, closed)

    Plus there is a button for Delete and one for Transfer

    That's it. No sign of anything related to file sharing.

    PS: I run Zotero for Firefox.
  • Library Settings are here:
  • edited May 19, 2017
  • (I assume you just reposting this was an error?)
  • edited May 19, 2017
    Nothing related to file sharing under Library settings. Only:
    - Group type
    - Library reading
    - Library editing
    - File editing
  • File editing is exactly what you want to be looking at. What's selected there?
  • "Any group member" which I thought was to allow all members to add and delete files...
  • Should be, yes. And you're sure your copy of Zotero is syncing successfully? No red exclamation mark next to the sync icon (the round green arrow)?
  • edited May 19, 2017
    No red exclamation marks or such. I have used Zotero for a number of years and like to think that I know what I'm doing. Should I try resyncing again?
  • By the way, the "Attach stored copy of file..." is greyed out for all the file settings I have tested.
  • yeah, definitely sync again.
  • I have tried this and everything else that I can think of but to no avail. It is not possible any longer to store attachment and that makes Zotero more or less useless for us. There must be a way to debug this unwanted behaviour, or?
  • sure, but debugging starts with running through standard troubleshooting steps and we haven't heard from you in 3 days.
    What's the name of the group?
    @danstillman could you look at this?
  • edited May 23, 2017
    I have been travelling and just returned back home from the trip. The name of the group is "Angular Momentum Radio".
  • By the way, the "Attach stored copy of file..." is greyed out for all the file settings I have tested.
    Could you elaborate on this? To be clear, those options are always grayed out if no items are selected.

    Can you sync again, create an empty book item in the group, make sure it's selected, and check that menu again?
  • edited May 23, 2017
    1. The greyed out option is not what I asked about originally but something that I was asked to check for by adamsmith. What I want to do is to copy some of the collections from My Library to the group library. However, no attachments are copied in this process.

    2. Have synced (more than once), crated an empty book item, selected it and checked it. The "Attach Stored Copy of File..." button is still greyed out.
  • Those menu options are just a simpler way of checking if the library is set to allow file editing in the database.

    But there's something not right here if this isn't working for you. Can you provide a Report ID after syncing?
  • I have the same issue that file attachments are not copied to a group library. All settings described above are OK (syncing and library settings). However, I discovered something peculiar. When richt clicking an entry in the group library (an entry that should have a file attachment bus does not) and selecting Add attachment - Add file attachment, a file selection window opens. When I then select any file (e.g. any pdf), it attaches not that pdf but the original correct one that was intended to be copied!
    @dstillman: I just submitted report ID D1064666861 after syncing.
  • Correction: the last sentence is not true; it only seemed like that due to the Zotfile renaming of the attachment.
Sign In or Register to comment.