OpenOffice plugin problems

My system:

Zotero 1.5b1
Open Office 3.0.1
Zotero.oxt 2.0a2
Ubuntu 9.04 alpha

The problem: When clicking on insert citation or set document preferences, I get the following error:

"An unknown error occurred contacting Zotero. Please use the "report errors" feature from within Zotero (...)"

I checked the following:

- python-uno 3.0.1-5ubuntu1 is installed
- running zotero with debug on shows that zotero starts listening on localhost:50001
- tried removing the plugin and reinstalling, cleared out folder too
- tried reinstalling firefox plugin
- firefox is not in offline mode
- openoffice does not track changes

So where do I go from here, I need this to work soon, so any help appreciated. One thing I have wondered about: People seem to mention there being multiple entries for the zotero plugin in the OO plugin manager. I see only one, and its not expandable in any way.

  • Did you use the "Report Errors" feature (under the gear menu)? Send in a report after you get the error and post the Report ID here.
  • The option is grayed out, even after errors occur. Probably since communication between the OO plugin and zotero is not happening at all.
  • Do you see any debug output (e.g., a SOAP request) when you click the button? If not, it's likely some sort of Python problem.
  • Hi again, thanks for helping out Dan.

    If you mean when I click on the cite icon in OO, then no theres just the error message that I described above.

    Where should I start troubleshooting python? Can I make the OO pluging give me a debug output somehow?
  • I have a very similar problem. Here's my configuration:
    Zotero 1.5b2 or Zotero 1.09 (both result in exactly the same error by OO)
    Ubuntu 9.04 beta with all current updates
    OpenOffice 3.0.1 (Build: 9379)(ubuntu build) with OO plugin 1.04b
    python-uno 1:3.0.1-7ubuntu1

    Zotero works fine in firefox.
    I start OO while firefox is running.
    When I click on the 'insert citation', 'insert bibliography', 'refresh', or 'edit document preferences', I get the following error:
    "An error occurred communicating with Zotero. Please ensure Firefox is open and try again."
    When I click the 'edit citation' or 'edit bibliography', I get the correct error messages, like 'you are not within a citation' or something like that.
    The only error message I get from OpenOffice when it starts up from a console is:
    'unable to get gail version number'
    but nothing comes up in the console when I click the zotero extension buttons, only the popup window with the errors mentioned above.
    I also changed from open java to sun java, but the errors were the same.
    I hope we can track this down soon
  • Oups, I realised I should use the plugin 2.0a2. I removed 1.04b and installed 2.0a2. Now I get the same error as in the first posting here.
    I ran openoffice from the console again, and only got the same error:
    'unable to get gail version number'

  • I used 'Report Errors...' from zotero, and it gave me the following error messages:

    Failed to load XPCOM component: /usr/lib/xulrunner-

    Failed to load XPCOM component: /usr/lib/xulrunner-

    I got the error report number: 1164778058

    I installed xulrunner, and now the 'Report Errors...' is grayed out, and these files exist, so the above error submission is irrelevant. The OO plugin still doesn't work, with exactly the same error message.

  • There is/was an issue with python in the ubuntu beta.

    Perhaps it is related.
  • I have this problem in Ubuntu 9.04 beta too.

    My setup:
    Zotero 1.5b2
    Zotero.oxt 2.0a2
    python 2.6.1-1ubuntu7
    python-uno 1:3.0.1-7ubuntu1 1:3.0.1-7ubuntu1

    There is no error output relevant to zotero in the debugging output

    @Sebastian - my version of python is later than the known bad version from ubuntu.

    The localhost http server is starting up, but the OO extension doesn't seem to be connecting to it. I can confirm that the same combination of plugin and OO profile is working in 32 bit intrepid.
  • I too have the latest python and still get the connection problem. I ran both firefox and openoffice in sudo to make sure it wasn't a priviledges issue, but that didn't solve it. I also ran
    strace -o /tmp/strace.log -f -tt -s 512 ooffice
    I'm no openoffice expert, and the file is quite huge, so I couldn't figure much out from that.
    I use the same versions in Intrepid (Ubuntu 8.10) with latest python updates, and it works fine.

    Does anyone know how to get verbose output from the oxt extension? That might help pinpoint the problem.
  • Same issue here:

    Ubuntu: Jaunty Beta
    OpenOffice 3.0.1
    Python 2.6.1+, 2.6.1-0ubuntu9
    Python-uno: 3.0.1-7ubuntu1
    Zotero Plugin: 2.0a2
    Addon: 1.5b2

    I get no errors from console when loading OO aside from:
    ** (soffice:7571): WARNING **: unable to get gail version number

    When clicking 'Insert citation' I get:

    'An unknown error occurred contacting Zotero. Please use the "Report Errors" feature from within Zotero to report this to the Zotero developers.'

    In Zotero, the 'report errors' option is greyed out... Can I get you any more information?

  • Same problem

    Failed to load XPCOM component: /usr/lib/xulrunner-

    report id 1806329190

    Suspect this is an Ubuntu problem, it is beta for a reason :)
    Updating stuff, trying to track it down.
  • OK pretty sure it's a Python / Ubuntu problem.
    /usr/lib/firefox-3.0.8/ `which ldd` -r /usr/lib/xulrunner-

    and got => (0xb8031000) => /lib/tls/i686/cmov/ (0xb7ffd000) => /usr/lib/ (0xb7ff9000) => /usr/lib/ (0xb739d000) => /usr/lib/ (0xb7399000) => /usr/lib/ (0xb7394000) => /usr/lib/ (0xb735e000) => /lib/tls/i686/cmov/ (0xb735a000) => /usr/lib/ (0xb7106000) => /lib/tls/i686/cmov/ (0xb7101000) => not found => /usr/lib/ (0xb7012000) => /lib/tls/i686/cmov/ (0xb6fec000) => /lib/ (0xb6fdd000) => /lib/tls/i686/cmov/ (0xb6e79000)
    /lib/ (0xb8032000) => /usr/lib/ (0xb6e59000) => /usr/lib/ (0xb6e33000) => /usr/lib/ (0xb6d7e000) => /lib/ (0xb6d68000) => /usr/lib/ (0xb6d64000) => /usr/lib/ (0xb6c75000) => /usr/lib/ (0xb6c61000) => /usr/lib/ (0xb68b0000) => /usr/lib/ (0xb6823000) => /usr/lib/ (0xb6808000) => /usr/lib/ (0xb67de000) => /usr/lib/ (0xb67c4000)

    So that, I guess is the problem: => not found

    But have no idea how to fix it ...
  • Today's package updates fixed the problem for me. I think it was an uno update that did the job.
  • Yup, it's working now for me too..
  • Working for me now too.
  • Fixed here - updates have fixed the issue...
Sign In or Register to comment.