Run-time error 91

I am using Zotero on MS Word 2003 under XP, but get a run time error 19 'object variable or With block variable not set' when I press any button on the word Zotero Toolbar. Any ideas?

BTW, it worked fine on Word X on my mac at home.
  • This was caused by a corruption in my visual basic installation... It is fixed now.
  • How did you fix it? Please tell.
  • edited February 6, 2008
    Hi Ravith,

    I just ran into the same error. It happened after I updated first zotero (1.0.2 to 1.0.3) and then the MS Word plug in (i use word 2003, too).

    I managed to get rid of the error by simply pushing the "insert zotero bibliography" button while looking at the bibliography in word (having the cursor just below the existing bib)
    Normally you would want to "edit bibliography" to add to existing bibliography. But this didn't work today, resulting in the above error message.

    "inserting zotero bibliography" replaced my old bibliography and obviously added a 2nd identical one beneath. Just deleted that "old" first one and everything is well again.

    PS: i doubt, sherpa_p+ will answer 'cause his problem occurred almost a year ago.
    Hope this is helpful for anyone anyways!

  • Hi again,

    i'll take my solution back. it only worked once but is not reproducible.

    After restarting word, the newer bibliography is back, but when I try to edit it or now even when i try to insert a new bibliography, the "visual basic runtime error 91" returns.

    sorry for my quick shoot!

    happy to hear if anyone else resolved this issue. I'll continue my search 'cause i really need it to work.

  • Hello again,

    still can't get my bibliography to work in my thesis.
    Same Run-time Error 91, interestingly the "debug" button is deactivated?!? Is that the way I secured my machine, don't I have a debugger or is it deactivated by zotero default?

    I tried a reinstall of MS Office 2003, a Microsoft Cleanup Tool (they suggest that), a reinstall of Visual Basic Runtime, creating a blank document with a new bibliography.
    Nothing worked. (oh, sorry, I'm running XP Pro SP2 with all updates).

    Guess, I'll have to do it the old-school way then...unless, someone has an idea what might be wrong on my PC...

    So long, slippi
  • Unplugging your network cable, or switching off wireless will probably make it work. I think it's something to do with using a proxy to access the internet, but I'm still investigating.
  • For additional discussion:
This discussion has been closed.