Word Mac 2015 Add In Standalone Error, wants to connect to Firefox

I used the following links and the 2016 instruction to install the Zotero Add In for Word 2015 (same issue).

I am using the latest standalone version for Mac.

I can see the Add In menu now, however, when I try to click on any of the options all I get is an error message, saying "Word could not communicate with Zotero. Please ensure that Firefox is open and try again."
  • Could you confirm the location of your startup folder and the Zotero.dot? Everyone we have had with that error on Word 2016 had their startup pointed to a non-standard location.
  • I choose the startup location through word (following the Word 2016 instructions) and the zotero.dot is in the startup folder, i can now also see the add in menu bar.

    I tried installing the firefox version of zotero plus the word plugin but won't work either =(
  • No, the mention of Firefox is just old, that's irrelevant.
    What I'm asking is for the exact file path of the startup folder in which you've placed Zotero.dot.
  • edited May 11, 2016
    My computer is in German so:

    changed it to the "real" (~/Group Containers/~) one that I found using Spotlight-Search and set it as the startup folder in word, but still the same issue. Yes i deleted the one in the old startup folder and tried reinstalling zotero.
  • OK, getting closer -- I'd still want to see the full path. You can xxx out your username if that's an issue for you.
  • nope, I was just being lazy :)

    Benutzer/Apple Flegel/Library/Group Containers/UBF8T346G8.Office/Benutzerinhalte/AutoStart/Word
  • OK that looks good. Could you confirm your Zotero version? You should have 4.0.29.x
  • thanks btw,
    it's 4.0.20 and it tells me there are no updates available
  • Updates from old versions aren't currently working on OS X, but you can install the latest version from the download page.
  • Hey,

    so i downloaded the latest version of zotero through the webiste and now everything is working as it is supposed to. Thanks a lot for the support!
  • I have the same problem.

    Zotero is

    and the start up file is here: /Users/rachelgermanier/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word

    I get the 'cannot communicate' message too. Can you help PLEASE??
  • This is Zotero for Firefox, right? Could you also confirm the version of your Zotero Word add-on? You'd check this in Firefox in the add-ons screen (about:addons) by clicking on "More" under the "Zotero Word for Mac Integration".
  • edited July 1, 2017
    Unfortunately I am experiencing the same problem, "Word could not communicate with Zotero" even if Firefox (or the Standalone) are open. I used for few years Word for Mac 2011 and never had a problem with Zotero.

    Recently I installed Word for Mac 2016 (ver. 15.35) and I could not see the "add-ins" section to use Zotero. After following some instructions I found on this forum (things related to the Zotero.dot file and the Word startup folder in "Preferences-File Locations") I managed to have the "add-ins" section appearing on the toolbar, and all the Zotero icons are there now.

    Yet when I try to use it, add a citation etc, it can't communicate with Word. I reinstalled the Word plug-ins for Firefox and for the Standalone. I am not sure what else I can do.

    Since my Word2011 still functions with Zotero, I am keeping it, and maybe there is some form or other of conflict with the Zotero.dot files (or they're in the wrong folder or else). On my hd there are currently three zotero.dot files, and I am not sure which one belongs to which version of Word.

    Can someone help please?
    Zotero Word for Mac Integration 3.5.14, Standalone
    These are the full path for the zotero.dot files I have on my drive:
    1) /Users/Scarifier/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word

    2) /Applications/Office/Startup/Word [This is the startup file I assigned in Word-Preferences-File Locations-Startup to solve the "add-ins" problem I had at the beginning with Word for Mac2016]

    3) /Applications/Microsoft Office 2011/Office/Startup/Word

    Thank you in advance for the support!
  • @adomasven if you could take a look at this? Settings look right to me.
  • @Scarifier could you submit a Debug ID for startup? You will need to check "Enable after restart" under Debug Output Logging in preferences, restart Zotero, attempt an operation from Word 2016, then submit the Debug Log and post the ID here.
  • @adomasven This is the debug ID: D1710529009

    Thank you for this!!
  • Seems like your Zotero for Firefox does not have the word plugin installed. Could you produce the Debug ID again, except with Standalone while Firefox is closed?
  • Here: D1177247349

    It's weird for, as I explained above, everything still works just fine with Word for Mac 2011 I still have.
    Could it maybe be related to the fact I have two versions of Word for Mac installed?
  • Oh wait. Did you copy the Zotero.dot file into the startup directory manually? Can you remove it, then go into Standalone Preferences -> Cite -> Word Processor Integration and reinstall the word integration, then try Word 2016 again?
  • Yes sure, but which one of the two zotero.dot files I listed above?

    1) /Users/Scarifier/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word

    2) /Applications/Office/Startup/Word [This is the startup file I assigned in Word-Preferences-File Locations-Startup to solve the "add-ins" problem I had at the beginning with Word for Mac2016]
  • Actually, that won't work, since you've assigned a custom startup directory (which is generally unrecommended). Instead, can you remove Zotero.dot and replace it with this Zotero.dotm file?
  • Yes, sure, but once again, where?
    I have two zotero.dot files in two different folders. Maybe both?

    1) /Users/Scarifier/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word

    2) /Applications/Office/Startup/Word

    I guess it doesn't matter since it's not working anyway?

    In relation to the custom startup directory, I had to follow that procedure so that the "Add-Ins" menu with Zotero would appear in Word2016, according to the guidelines I found on this forum
  • edited July 6, 2017
    oh... It seems to be working now. I substitute both zotero.dot files with the file you attached here.

    It works now. Thank you so so much for your support!
    Weirdly enough, the "Add-Ins" menu (with Zotero and Zotero 'buttons') in Word 2016 disappeared, but a "Zotero" one appeared now.

    So, why did this happen? What's this .dotm file I did not have installed on my mac? I am asking just to understand what went wrong.

    Once again, @adomasven thank you very much for your support!
  • The story is kinda complicated due to a bug in 2016 which sometimes makes the .dot file not work and we have not found a way to replicate the bug on our end to troubleshoot it, but there have been reports.

    1. Zotero.dot has been updated a couple of years ago for compatibility with 2016, due to some changes in the newer Word version.

    2. When you created (2) you probably copied Zotero.dot from (1), which was not updated to work with Word 2016, but changing the startup directory may have resolved the bug which made it not show up at all.

    3. The Zotero.dotm file is an updated Plugin UI file for Zotero 5.0, to be released soon, and it also does not seem to trigger the bug where the UI won't appear, so I just pointed you to it, to make sure you have a current version.

    Ideally you would switch back to the original startup directory for Word 2016, as Zotero and other applications expect that location and when updates come, that is where they will be installed, but won't show up for you.

    If you want Word 2011 to remain working, you should keep both the old Zotero.dot and Zotero.dotm files in the startup directory.
  • Thank you for all of this. I put back the zotero.dot file in the Word2011 folder and it works. I also switched the Word2016 startup folder to /Users/UserName/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word as you suggested and everything still works.

    I hope nothing will change with new updates.

    Thank you very much for all your help and support!
Sign In or Register to comment.