Abbreviations for figure, number, etc. are being made plural when only singular

An odd, and inconsistent mistake I'm having when adding citations in Microsoft Word for Mac 2011 with Zotero 4.0.29.8.

When I go to enter the page field, if I include additional location information after a comma after the page numbers, Zotero sometimes adds an 's' to the item, but not always. For example:

Enlart, Gothic Art and the Renaissance in Cyprus, 370, fig. 335.

but

Enlart, Gothic Art and the Renaissance in Cyprus, 367–68, figs. 333.

I don't know if this is because there is a page range in the second example, but if you have a way to resolve this error, I would be most grateful. In each case it should only read 'fig.' which is what I typed in the insert citation field in word.
  • this isn't technically supported at all (Zotero/CSL don't handle multiple locators at this time), so fbennett would have to say how he coded this in the processor. I'd be pretty sure this is due to the page range, though, yes.

    You could obviously always handle this using "fig. 333" as a suffix. Less elegant, but will do for most purposes.
  • I see. Thank you. Using suffix helps. FWIW, when I typed p. as an abbreviation in a note, it generated the following:

    Nielen, Lignages d’outremer, Le Vaticanus Latinus 4789, no. 337, page 99; no. 346, page 110.

    So, it properly generated "no." but expressed p. as "page", which I didn't want.
  • that's likely the citation style. which are you using?
  • This was a bug in the processor, which as adamsmith says goes beyond the CSL specification, to localize and pluralize locator labels embedded in the field. I've squashed the bug, and you can try the new version by installing one of the Propachi plugins.

    The plugin can (and should) be removed when the next Zotero release comes out, but in the meantime it should yield correct output with the original "367-368, fig. 333" input at the top of the thread.
  • I'm experiencing a similar problem to that of the original poster. I am using Chicago Manual of Style, 17th ed. (note).

    I enter "380, fig. 11.1, 382, fig. 11.2" into the page field. I would like my citation to read the following way:


    Justeson and Broadwell, “Language and Languages,” 380, fig. 11.1, 382, fig. 11.2.


    but, it is expressed as the following:


    Justeson and Broadwell, “Language and Languages,” 380, figs. 11.1, 382, 11.2.


    I must adhere to Chicago Style so workarounds such as "380, fig. 11.1, p. 382, fig. 11.2" isn't an option. Is my only recourse to correct each citation manually? This is doable, but following any modifications, the citation will no longer update manually, and if I need to add another source to the citation, for example, my edits will be lost.
  • *update automatically
  • I'd just use suffix to enter information of this complexity. If you add page 380 and then suffix ", fig. 11.1, 382, fig. 11.2" that should work nicely.
  • Thanks very much for this!!
  • edited 11 days ago
    Now if only I could find a way to intersperse citations with regular text...

    NVM figured it out. ;)

  • I did take a look at this problem, and explored how it might be handled in code. I began to think that while it's possible to set up an escape mechanism that will cover the use case, the better course would be to have some option or markup that (almost) completely disables smarty-pants rendering of the locator string. That's a larger discussion -- and the suggestion of @adamsmith gets you there immediately, so long as you're citing in Chicago (the style, not the city :).
Sign In or Register to comment.