"Duplication of tagged items" bug/feature?

For entering multiple articles from an edited volume I usually grab the volume itself from the library catalog, then duplicate the items and change the info on the respective chapters. When I tried this with the beta, I received this error message:
Duplication of tagged items is not available in this Zotero release.
Will this be fixed in the final release? Or is this actually a feature? If so, I'd like to hear an explanation what's wrong with duplicating tagged but not untagged items. Or is there a better way to deal with multiple chapters from an edited volume?

Thanks a lot! The beta looks great.
  • It is indeed a bug.
  • This sounds like an easy fix. If so I vote for high priority. If you deal much with edited volumes it disrupts the natural workflow and ends up creating a lot of frustrating, tedious work.
  • I'm pretty sure this was fixed in 1.5b1 but has reappeared in 1.5b2
  • alexuw, this hadn't been fixed in b1. Quite on the contrary: the problem, at least for me, showed up for me the first time in beta1 (I didn't use the preview version, though). Too bad this wasn't taken care of in b2.
  • I guess I was dreaming. I swear it went away for a while.

    I duplicate items all the time as a work-around for not having a better way to deal with edited volumes. This bug is fantastically annoying.
  • Yeah, I agree, the bug is indeed annoying. I wonder if people are using the function for anything other than dealing with edited volumes. Ideally, that problem would be solved on a more fundamental level, like introducing parent-child relations with inherited attributes for items.
  • I can imagine a few unlikely use cases, say if you're manually entering a number of articles from the same issue of a journal.

    And yes, duplicating to define sections of edited volumes - this is a kluge. The planned solution is a hierarchical model. According to this it's slated for 1.5 but I wonder. Seems to me like it would be a pretty big job.

  • Note to devs: I can't find a bug report for the "Duplication of tagged items is not available in this Zotero release" problem. I signed up for trac so I could enter one but apparently I don't have sufficient privileges.

    For the record, it looks like it's not really a bug per se but rather was intentionally done in this change, but no explanation why.

  • You misunderstand that changeset; it was known that duplicating tagged items was broken:

    Rather than throwing an uncaught exception, all duplicates were disallowed & issued that informational message (pending a fix). The changeset you link to limited this restriction only to duplications that were actually broken.
  • Seems like 2.0b3 has taken care of the duplication problem. Thanks!
  • Yes, it's fixed. Closing this thread.
This discussion has been closed.