ZotFile: Zotero Plugin to rename, move, and attach PDFs, send them to iPad & extract PDF annotations

1454647484951»
  • @ben.hjorth Sorry, I can't reproduce either of those problems. I am leaning to thinking that something is wrong with the installation/file structure of Zotfile or Zotero on your system. Do the problems persist if you install them on a different computer (for testing)?
  • Yes, I keep downloading Zotfile again and again (I'm not a Firefox user normally, so maybe it did not do it properly). When I told you that I added a Dropbox subfolder in Zotfile, I meant from the Zotfile preferences (which I accessed on Firefox).

    Zotero version: 4.0.29.15
    Firefox: 52.0.2 (64-bit)

    Could the problem be linked with the fact that I have always used Zotero Standalone until now (with Chrome), and that there is a problem since I changed, for instance on the repository?
  • My first recommendation would be to just go back to using Zotero Standalone. The Firefox-based version will be discontinued very shortly when Zotero 5.0 is released (currently in Beta and very close to ready).
  • I did. And it works perfectly! :)
    Sorry for disturbing you for nothing, I will now discover Zotfile!
  • thanks @bwiernik - yes the issue is the same across both PC and Mac versions of Zotero Standalone 5.0-beta.180+de7b56b and Zotfile 5.0.0b3. I'm also not the only one experiencing it - see here on github where at least two others report the same problem: https://github.com/jlegewie/zotfile/issues/268.

    could it be related to using Dropbox for my storage directory? to repeat, the path is
    Users\bensefth\Dropbox\zotero\library, with %c entered as the subfolder definition. So, instead of (for e.g.) Dropbox\zotero\library\masters\hegel they're being saved in Dropbox\zotero\library\undefined\masters\hegel, etc.

    I did see something upon installation of Z5 warning against using Dropbox - however for me there's no real alternative in terms of having my attached documents available on multiple computers. tho I have also been getting strange behaviour on both the PC and Mac where the "Conflict resolution" screen flashes up (and then immediately disappears) a few times whenever I add a new file on either machine, and I had wondered if this had anything to do with using Dropbox, which obviously syncs itself independently of Zotero as well...

    as for why the author/editor issue can't be replicated, that remains an absolute mystery to me, but is of far lesser importance than this problem.

    thanks again @bwiernik really appreciate your help
  • The warnings against Dropbox only apply to storing your Zotero database in Dropbox. Using a cloud drive as your Zotfile folder shouldn't be a problem.

    Do you mean Zotero's or Dropbox's conflict resolution window?
  • edited 2 days ago
    I *did* have my database in Dropbox... I wasn't aware this was such a problem. Tho now I read you commenting elsewhere that "It takes a lot of diligence to be sure that no Dropbox sync is ever running when the database is open in Zotero, which will cause corruption." eek. I have not exercised said diligence. Is my database likely to be corrupted? Can this be repaired?

    I have now moved the Data Directory location back to the default, i.e. my laptop hard drive - I understand that it will still work on different machines via Zotero's own online sync. I also moved the "Linked Attachment Base Directory", which had also been set as Dropbox, to the hard drive. Tho my understanding is that this isn't particularly relevant to me, as I rename/refile everything via Zotfile - to the "library" folder and %c-defined subfolders (preceded by the mysterious "undefined") on Dropbox.

    I have also updated to 5.0-beta.182+d472752 on the Mac (running Sierra 10.12.2). Not currently able to change the settings on the PC but the computer should be asleep, so not syncing.

    And yes the conflict resolution window is Zotero's - it flashes up and immediately disappears. It's still doing this after changing the database location and the update.
  • A small feature suggestion for Zotfile.
    I frequently use HTML formatting in title fields, especially around things like book titles in article titles to italicize them. Zotfile handles this by replacing <i>Word</i> with iWord-i, which is fine, but it would be more elegant to drop the tag and its contents entirely.
    So my suggestion is to add a checkbox option such as "Ignore HTML tags" to the Zotfile preferences, which would instruct Zotfile to simply strip away anything between angle brackets.
  • You should not be placing entire fields in HTML markup to format them. That should be done using the CSL style. Markup should only be used to style specific words within a title (e.g., to italicize species names in biology).
  • edited 2 days ago
    Sorry if I wasn't clear--I'm not using tags to markup entire fields, just terms within them such as foreign words. By "book titles in article titles" I meant italicized book titles that are mentioned in the title of an article, e.g., "No Elephant in the Room: The Absence of Pachyderms in Hamlet." My ideal outcome would be that the filenames that Zotfile creates for such titles skip over the HTML tags.
  • Hi,

    I was hoping someone could help me. Essentially Zotfile is extracting incorrect annotations.

    I am using windows and the firefox zotero version. I can annotate PDFs fine and these are saved appropriately in the child file in zotero.

    Zotfile seems to extract the annotations but they are all incorrect and not what I have highlighted at all.

    Incidentally I am using a Surface Pro 4 with surface pen to highlight on windows 10. I don't know if that should make a difference.

    Thanks in advance for the help.
  • What (software) are you annotating with/on exactly? I'd try Acrobat to be sure you're using something that others have tested.
Sign In or Register to comment.