ZotFile: Zotero Plugin to rename, move, and attach PDFs, send them to iPad & extract PDF annotations

1444546474850»
  • Hi Tsau017, it wasn't on the list, but I've unchecked the option and restarted, and I'm still having no luck. I'm wondering if part of the problem may be that macOS appears to treat the epub as a package/folder, rather than as a folder.
  • hi, apologies if this has already come up -- I didn't seen anything quite like it on a seach. I've successfully downloaded and installed zotfile and having been playing with the renaming rules to suit my preferences, but they seem to have become stuck. In the plugin preferences, I have for "Format all types except patents":

    {%a } - {%t} ({%y})

    with "Change to lower case" checked, and the "Use Zotero to rename" box unchecked (checking it doesn't seem to make a difference). When i use the "Update" button in preferences (for a preview of the renaming rules) it works correctly, e.g. it will show:

    walton - ramus and bacon on method (1971)

    But if I actually run "Rename File from Parent Metadata" in Zotero, the file will be renamed in this format (for comparison):

    Walton - 1971 - Ramus and Bacon on method.pdf

    These settings correspond to a previous set of renaming rules (i've been trying different rules); it worked correctly at first but, like i said, it seems to be stuck with an older set of renaming rules that won't update. I have tried removing and reinstalling the plugin after re-downloading, restarting Zotero, restarting my computer, etc., and nothing seems to work. Any help would be much appreciated. thanks -
  • The "Rename File from Parent Metadata" function is the native Zotero renaming function. To use Zotfile's format, look lower in the context menu to Zotfile's section: Manage Attachments -> Rename attachments
  • thanks, bwiernik --
  • Identified by adamsmith as a zotfile error - please see Zotero Forum Discussion item https://forums.zotero.org/discussion/63547/zotfile-tablet-transfer-error#latest

    Essentially I have 4000+ items in my library that I wish to send as pdfs to a new HDD folder - call it C:\Zot_temp. Most, but not all, of these items have previously been sent to a different HDD folder (e.g. C:\Zot_pdfs) after retrieving metadata from pdf. When I now select the items & use "Mange Attachments" -> "Send to Tablet" I get the error msg captured on https://www.dropbox.com/s/zsypyg9zmw7sp1u/Zot1.docx?dl=0 (see towards end, and also most recent comments by adamsmith on above Zotero Discussion thread). No pdfs get transferred over.

    Using latest Windows 10 updates & Zotero 4.0.29.10 with zotfile 4.2.7 (updated 13.11.2016).

    Many thanks Richard
  • In case anyone here may find this useful, I made some tweaks to get Extracted Annotations in different in-text citation formats.

    See:
    https://github.com/jlegewie/zotfile/issues/175

    Many thanks for Zotfile!
  • Just a quick recap (concerning only 2 points):

    How to just move files without renaming? (= change folders but not file name)
    In Zotero Standalone, go to Actions->Preferences->Advanced->Open about:config. Set extensions.zotfile.disable_renaming to true


    How to move any attachement (not only pdf, text…)?
    In Zotfile preferences > Advanced Settings > uncheck "only work with the following filetypes (or leave it checked and add your extensions)
Sign In or Register to comment.