Youtube video translator doesn't work anymore (devicesupport URL)

When I try to add a youtube in my library, the link and the title are "" (a very famous video indeed) instead of the video I'm adding.

I found on google that I'm not the only one who get that problem.

I looked into the translator file (I'm a beginner), but I found out that the address used to retrieve data ( ) is no longer valid, see the explanation by youtube here:

So I did not manage to solved this, your help, an translator update would be highly appreciated.
  • edited May 29, 2015
    OK, I'll try to take a look over the weekend, but have lots going on, so might take a little longer.

    Edit: might not be easy -- the v3 API requires registration, I'm not sure we can do that, given that the translator code is public.
  • Based on their ToS and this looks like we're out of luck for now. We can probably come up with some non-API based scraping though.

    In the long run, it may be worth thinking about a way to allow users to easily register their accounts with various APIs so we don't have these issues.
  • edited July 5, 2015
    Thanks Adam and Aurimas, that's too bad youtube is making it difficult. I hope you will find a work around. I warmly thank you for the time you spend on Zotero.
  • Any update on this? I tried to download via YouTube and it failed, for obvious reasons. If it's not working, is there a way to pull it from the code, so users don't waste their time wondering why it's not working?

  • we finally have this fixed now. Sorry for the delay.
    Your version of Zotero will automatically update within 24hs, or you can update manually using the "Update Now" button in the "General" tab of the Zotero preferences. If you're using Standalone, restart Zotero and your browser after updating.

    Any further problems let us know & thanks for reporting
  • Great, Thank you Zotero!
  • For YouTube videos, I'm occasionally seeing scraping options for the webpage, not the video Item Type.

    Mostly, I see the video scraping options - but these lead to the "Could Not Save Item" message.

    I'm using Zotero and Firefox 41.0.
  • could we get a couple of sample URLs, please?
  • Problem solved?

    I just got the prompt to upgrade to and the issues I was experiencing seem to have been resolved.

    Thanks anyway!
Sign In or Register to comment.