MS Word 2013 plug-in stopped working in single document

I was working with a document successfully for months, then today when I went to add a new citation it would not work and the following error pops up:

This command is not available because no document is open. code: "0" function: "zoteroWinWordApplication::GetDocument" location: "zoteroWinWordApplication.cpp"'This command is not available because no document is open. code: "0" function: "zoteroWinWordApplication::GetDocument" location: "zoteroWinWordApplication.cpp"' when calling method: [zoteroWinWordIntegrationErrorHandler::throwError]

If I open a new document it works, but if I copy and past into a new document the error recurs. I have tried restarting both Word and Zotero, syncing, breaking the link, etc.

On a side note, whenever my author reference has any kind of accent in it, a similar error occurs.
  • could you provide a debug ID from Zotero that covers triggering that error?
  • This is what I get:

    [JavaScript Error: "bad script XDR magic number"]

    version => 4.0.23, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Zotero, appVersion => 4.0.23, extensions => Zotero LibreOffice Integration (3.5.9.SA.4.0.23, extension), Zotero Word for Windows Integration (3.1.17.SA.4.0.23, extension), Google Update (, plugin), Adobe Acrobat (, plugin), Microsoft Office 2013 (15.0.4545.1000, plugin), Microsoft Office 2013 (15.0.4514.1000, plugin), Silverlight Plug-In (5.1.30514.0, plugin), HP ProtectTools Security Manager (, plugin), IntelĀ® Identity Protection Technology (, plugin), IntelĀ® Identity Protection Technology (, plugin
  • It just started happening when using Word 2013. I have reinstalled Zotero and the Word plug-ins but it doesn't stop the errors. Additionally sometimes when I click the 'Zotero Bibliographic Management: Zotero Insert Citation' in the Add-Ins tab it is non-responsive. It happens completely at random.

    The Debug ID is D355017334

    Computer Specs: HP ProBook 450 GI, 64-bit Operating System, Intel(R) Core(TM) i5-4200M CPU A 2.50GHz, 4.00 GB RAM
  • I also noticed that this problem happens when I save a document to Microsoft OneDrive, but I tried saving the document to my computer and Zotero continues to work for it. I suspect the problem might have to do with Microsoft OneDrive.
  • edited November 8, 2014
    That's a little odd--I know saving to Dropbox works--but it's certainly conceivable that OneDrive would lock the document or otherwise disallow Zotero to communicate with it, e.g. while it's syncing or so. I don't think we'd be able to do anything about that, unfortunately.

    Might be worthwhile exploring a different cloud solution, since having important documents in a syncing folder seems eminently reasonable/wise.
  • I wonder if the error "This command is not available because no document is open" is related not to OneDrive, but to multiple instances of Word running.
    Deiphobe, if you still experiencing this problem, does it happen when only one instance of Word is running?
    If you are not still experiencing the problem, what was your solution?
  • hi everyone
    i noticed a problem like that the day before. reinstalled word and zotero but the problem did not stop. opened a new document and both zotero and word worked fine. i dont know it is a real solution but i saved the document as word 97-23 format, did a citation than.. bingo. worked fine. than saved the document as 2013 format again and now it works as i want :))
  • This is happening to me and is definitely related to OneDrive. If I save the document to my desktop, Zotero in Word works fine. Move it back to OneDrive, and I get this error:

    This command is not available because no document is open. code: "0" function: "zoteroWinWordApplication::GetDocument" location: "zoteroWinWordApplication.cpp"'This command is not available because no document is open. code: "0" function: "zoteroWinWordApplication::GetDocument" location: "zoteroWinWordApplication.cpp"' when calling method: [zoteroWinWordIntegrationErrorHandler::throwError]
  • Added to troubleshooting:
    Thanks everyone for following up. Unfortunately, I don't think a solution is in the cards any time soon.
  • Hi everyone, any updates on this?
  • The problem I was experiencing resolved itself.
  • Interesting, what did you do?
    I am still experiencing this issue in Office 365 /Word 2016 so wondering whether reverting to a previous version of Word might help.
  • I'm running Office 365 / Word 2013. I'll upgrade to 2016 and report whether the problem recurs.
  • I experienced the same sort of problem working with one drive. every time I tried to add a citation the Word stopped responding. I found that the moment I turned off Autosave. The problem disappeared.
Sign In or Register to comment.