Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorRM
    • CommentTimeSep 8th 2008
     
    I recently installed Zotero 1.5, and I now notice that my Firefox is starting slow. I double click the icon, and nothing happens for several seconds, not even a cursor change. Previously, the Firefox window was up after just 1-2 seconds. Disabling Zotero in Tools->Add-ons restores the previous speedy startup behavior.

    Anyone else have this problem? Is there any settings I can change to reduce the Zotero burden in Firefox Startup (e.g. deferring processing until I actually click on the Zotero icon)? Any other suggestions?

    BTW, Zotero 1.5-sync2.1 on Firefox 3.0.1 on Windows XP.
    • CommentAuthorRM
    • CommentTimeSep 8th 2008
     
    I did some testing, and it seems that the slowdown (~18s for Firefox to start, compared with ~6s with Zotero disabled) only happens the first time I open Firefox after restart. Reopening takes the same amount of time with and without Zotero (~2s). Going to the Sync tab in Zotero preferences and disabling Data and File syncing did not improve startup times.
    • CommentAuthormishas
    • CommentTimeSep 9th 2008
     
    same problem here. could this be due to the once-a-day software update check?
  1.  
    With a large Zotero library and/or on slower computers, there may be a delay the first time you open Zotero after a restart, but just having Zotero installed shouldn't have much of an effect on Firefox start time.

    1) How many items do you have? (Click an item in the middle pane, Select All, and look in the right pane to see the number of top-level items.)

    2) Start Firefox with debug output enabled and see if there are any lines where there are long delays.
    • CommentAuthormishas
    • CommentTimeSep 9th 2008
     
    1) 38. so not that many, methinks.

    2) restarted windows and ran Firefox as you suggested, but there was no slowdown. since i got "zotero(4): Not enough time since last update -- not checking repository" this doesn't really do anything for my theory. will try again tomorrow, if i don't forget. :)
    • CommentAuthormishas
    • CommentTimeSep 9th 2008
     
    BTW i'm not running 1.5, i'm on 1.07 with FF3.01
    • CommentAuthorRM
    • CommentTimeSep 13th 2008
     
    1) None. I added one or two accidentally, but I deleted them afterwards. My slow starting is with an "empty" database.

    2) Items scroll by steadily. I then tried setting both debug.log and debug.time to true. (debug.level is at the default 5). The largest number is for "zotero(4)(+0002741): Translate: Binding sandbox to http://www.google.com/" (Google is my homepage) followed by at "zotero(4)(+0001554):Registering observer for [collection,search,share] in notifier with hash Xr", although I can't say the scroll "hangs" at either. The rest of the numbers are +0000200 and below. (Both data and file syncing were enabled for these trials.)

    It's probably not a daily update, as I can consistently get a 10+ second startup time multiple times in a row simply by rebooting my computer.
  2.  
    RM: Can you send the timed output to support@zot....org?

    Do you get the same slowdown if you just quit Firefox and restart it without restarting your computer? Also, what are your hardware specs?
  3.  
    I am also have a problem with Firefox starting slow. It has only happened in the last week or so. Takes about 20 seconds to open. I am using FF portable and a user specified directory for Z.
    Firefox Portable: 3.0
    Z: 1.5-sync2.2
    352 refs.
    From the timed output I think that it is updating the translator every time. I am sending a copy to the support email address.
    I switch around computers but they are all modern: > 1 Gb RAM, Pentium 4 ~3GHz.
  4.  
    Stuart: Thanks for the debug output. It does look like sync2.2 is incorrectly updating the translators every time. We'll fix that.

    But, judging by your debug output, it's still taking way too long for you. Does the "Cached 267 translators in.." line take ~7 seconds every time? Do you have both Firefox and the data directory on a USB drive? Is the USB drive flash or hard drive?

    In our testing, it should take well under a second on recent machines.
  5.  
    My library normally comes of a new external Western Digital hard drive.

    I have synced my library with my laptop to test the startup speed. Zotero and FF (both latest versions) run off the internal hard drive. Without the library FF started up in a second or so. After syncing my library it takes the 20-30 secs that I see on my other computers. Anything I can do to help with tracking down the bug? I can send you the library if it helps.
  6.  
    Stuart: Can you start Firefox a few times with debug output and note the "Cached 267 translators..." lines (both before and after the translator updates) to see how long it's taking for each run?
    • CommentAuthorautocrine
    • CommentTimeOct 21st 2008
     
    I also have this problem. Firefox takes about a minute and a half to load up from the first double-click until I have a useable browser window. With the Zotero plugin disabled it takes less than five seconds.

    I have noted the console debug output as suggested above. Zotero spends a good second or two at each of the 267 "Updating translators" lines. In total I clocked the Updating Translators phase at 58 seconds, although the debug output reports a time of 3163 ms at the "Cached 267 translators ..." line. Once the translators are updated the lines whizz past in the console and the browser window quickly appears.

    I tried unchecking the "Automatically update translators" and "Report broken translators" option in the General tab of Preferences but this made no difference to either the total Firefox startup time or the time spent "Updating translators" in the console debug.

    I'm running FF v3.0.3 and Zotero 1.5-sync2.2 and I have this issue on two recent-model computers under XP and Vista.
  7.  
    The debug console itself on Windows is extremely slow, so stopwatch times aren't necessarily useful with the console open. Could you enable extensions.zotero.debug.time and then send the startup output to support@zot....org?

    Do you have anti-virus software installed? Anything else that might be slowing down disk access?
    • CommentAuthorautocrine
    • CommentTimeOct 27th 2008
     
    I just upgraded to Zotero v1.5-sync3.1 and the 'slow Firefox startup' issue has gone!

    Thanks!
  8.  
    It's probably not actually gone, just occurring less frequently because the upgrade-translators-every-startup problem is fixed. You may still see the delay when translators or styles are updated in the repository, which could happen fairly frequently, so it's still worth troubleshooting. You can probably reproduce it by clicking Reset Translators and Styles from the Advanced pane of the Zotero prefs. If the debug times are equivalent, I can provide (simple) instructions for how to profile the process in a JS debugger, though based on the debug output I suspect the problem is a more general issue with disk access than anything in the Zotero code.

    Are there any non-standard services running on your machine?
  9.  
    I also just upgraded to Zotero v1.5-sync3.1 and found the slow startup has gone. If I click Reset Translators and Styles the system only pauses for 15 seconds rather than the 30 seconds I had before.
    My greatest problem with zotero at the moment is the lack of documentation. I tend to stumble upon some of the great features E.g. changing title case, saved searches. A minor gripe.
    • CommentAuthorRM
    • CommentTimeNov 2nd 2008
     
    Sorry for the delay in getting back - I've been busy with other things.

    Since I'm now updated to Firefox 3.03 and Zotero 1.5-sync3.2 (Still on Windows XP, with all updates applied) I decided I'd better redo the timings to see if things improved. Like before, slow downs only seems to happen at the first launch after restart - subsequent starts of Firefox without reboot are a uniform 2-3 s (All times are from double clicking the desktop icon to flashing cursor in the search box of the Google homepage). Note that I waited for the OS to finish loading completely before I started firefox, and I still have an empty Zotero library.

    For some reason the first time I tested it, the base time (with Zotero disabled) went up from before (now 16 s), but enabling Zotero still added several seconds (23 s total). Most of that extra time was with at blank Firefox screen with "looking up clients1.google.com" in the status bar. When I changed to "Show a blank page" instead of showing the Google homepage, I got a blinking address bar cursor in a speedy 2 s (Manually going to Google was an additional 10 s or so).

    Since I have a number of other extensions (NoScript, FlashBlock, etc.) I decided to see if they were slowing start-up (with a Google start page). I disabled a select few (down to 2 s), and then added them back one-by-one. Surprisingly, when I had reactivated all but Zotero, I was still at 3 s. Adding Zotero back gave a 13 s total startup. This time I deactivated everything (2 s) and then re-enabled Zotero only (8 s). Adding the others back in, and I had *decreased* to 6 s. (Again, times are for starting Firefox the first time after restarting the computer - subsequent launching of Firefox was a consistent 2-3s. Also, after disabling/re-enabling extensions I restarted Firefox before rebooting to finalize the changes.)

    If others are having slow startup problems, it may be worth going to the Tools->Add-Ons->Extensions tab, and clicking the "Disable" button for each entry there. Restart your computer, and then re-enable all the extensions. I don't know why it worked for me, but it seemed to help - I saw significant speed improvements each time after disabling and then re-enabling extensions.
    • CommentAuthorKID1410
    • CommentTimeNov 28th 2011
     
    My solution is I rebuild index again and my Firefox turn to normal... ^^

Zotero Forums are powered by Vanilla 1.1.5a