Error: Zotero can't access HTMLDocument.location during translation ScienceDirect

Zotero bug id 2111048607

Chrome code from the link below causes the problem
1. In firefox open page below:
2. Translate page to Zotero's reference.

for more details see:
  • As I noted on the RoboForm thread, I'm not sure there's anything we can do about this problem on our end, but we'll look into it, since it's come up before with at least one other extension (the RealPlayer Browser Record Plugin) and probably others. But if RoboForm is accessing the underlying Document object from chrome and causing its security context to be altered, it seems like that might be a bug in RF. I didn't write our translation code, though, so I don't know all the details here.

    At the very least, we'll look into it and see if there's anything we can do in the name of defensive coding.
  • Hi experts out there!

    I encountered a similar problem using the Zotero and NoScript addons.

    NoScript appears to block access to specific webpage elements that are required by zotero translators for retrieving and saving bibliographic information.

    Example: Bibliographic information on the page

    cannot be stored by zotero tranlators.
    The same error message results: "Permission denied to get property HTMLDocument.location"

    although Scripts and XSS are allowed for the website.

    If I deactivate NoScript completely, zotero works fine.
    But this is, of course, not an acceptable solution.

    What page elements might be blocked by NoScript?
    Can you give advice how to solve the problem?

  • I encountered a similar problem using the Zotero and NoScript addons.
  • This is fixed in NoScript (the latest unofficial development build). I've sent the patch they used to Ivan (from RoboForm), so hopefully it'll make it into RoboForm as well, since we haven't yet found a way to work around this on our end.
  • The relevant NoScript changelog line, by the way, was in "Work-around for newTabURL incompatibility"

    One of the reviews of the NewTabURL extension says, "Does not seem to work if RoboForm is running. Works fine if Roboform is removed." So clearly this affects more than just Zotero.
  • vvvi communicated with roboform support abot this.
    their final replay was as follows:

    John replied (2008/08/21 08:42 am EST)
    I have found that problem is caused by Firefox.
    And have create new bug in Mozilla bugtracker:

    You wrote (2008/08/15 04:34 am EST)
    hello again

    i'm using firefox 3.0.1 with zotero 1.07 and roboform 6.9.90 addon in winxp-sp3.
    zotero addon for firefox is downloaded on
    it's reference addon for academic use.
    after installing go for instance to :
    after the page is fully loaded, you'll see a small sheet icon in the address-bar on the right hand side (next to the bookmark star).
    when you press this icon zotero will translate this web page into a reference.
    BUT if the roboform addon is installed an error will occur, and the translation will fail. when i disable the roboform addon, zotero will retun to function normally.
    you can find another description for this problem at:

    again many thanks
    I really enjoy you product
  • itayhad: That was four months ago, and that's the same bug ivank linked to above (which Mozilla developers closed as invalid). If you would like this fixed, I would recommend contacting RoboForm again with another pointer to this thread. As I noted above, they're currently breaking a number of extensions, and there's a simple patch (which I've sent to Ivan) that other extensions have applied to fix the problem.
  • Sent bug report on this issue to Roboform last week, here is their reply:

    John replied (2009/02/04 10:46 am EST):
    The problem will be fixed in a next version of Roboform Adapter for Firefox.
    It will be a pack of changes with a heavyweight API improvements and serious compatibility fixes. It is now on beta stage.
    We will send you a working version to test in a week.

    Let's see what happens...
  • ROBOFORM bug fix:
    New adapter XPI file is linked below. It is beta version so we recommend to use it only for testing.
    The bug with Zotero is fixed but adapter has still some other regressions.
  • by the way
    i tried the new roboform adapter (in and it's working great!!!

    thanks everyone!
Sign In or Register to comment.