Exporting of Items with German "umlaut" (ä, ö, ü)


when I try to export items with German characters such as ä, ü, or ö for example to a BibTeX file I always get something like ö. The same is true for endnote or other formats. Is their a possibility to avoid this?

  • Make sure you have the latest version of the BibTeX translator by clicking Reset Translators and Styles in the Advanced pane of the Zotero prefs (this is only necessary for BibTeX and only in Zotero 1.0.*), and then make sure "Export as UTF-8" is checked when you export.
  • hi,

    after having reset the translators and styles, the following error message occurs during export: "An error occured while trying to export the selected files".
    As I just realeased, it is not possible to select only some items from the libary (or a collection) and export the selected items.
    I have used lytero for this so far. But exporting with lytero does not fix the problem with ä, ü, or ö.
  • Restart Firefox, attempt to export, and then send in an error report via Report Errors in the Actions (gear icon) menu and post the Report ID here.
    As I just realeased, it is not possible to select only some items from the libary (or a collection) and export the selected items.
    Do you mean due to this error, or generally in Zotero? Generally speaking, you can export only some items by right-clicking a collection or a group of selected items and selecting the export option.

    By selecting various groups of items, you should be able to figure out which items are causing the error.
  • hi,

    the report ID is: 2038360760
    But I found the source of the error myself. The error occurs when I tryed to export this item:
    Lang, Frieder R. 2003. “Die Gestaltung und Regulation sozialer Beziehungen im Lebenslauf: Eine entwicklungspsychologische Perspektive.” Berliner Journal für Soziologie 13:175.
    After adding "175-196" to the page field (and not only 175) the error disappeared.

    Thanks for your help!
  • After adding "175-196" to the page field (and not only 175) the error disappeared.
    OK, thanks. We fixed this recently on the trunk, but it looks like it's a problem on the 1.0 branch as well. Now fixed on the branch (for 1.0.8 and beyond) as well.
  • Hi,

    > Now fixed on the branch (for 1.0.8 and beyond) as well.

    Where can I find 1.0.8 or any 1.0 version beyond that one? The only versions I can find are 1.0.7 and the 1.5 preview.

    Thanks for your help.
  • 1.0.8 isn't yet available, but it will be soon.
  • Hi,

    I still have problems exporting items with non-Latin or "enhanced Latin" characters to BibTeX. There are currently two items that cause them.

    An article by N. Agraït results in this. Note the "ï" being dropped in the key and being replaced by "ï" in the author field:

    title = {Vertical inertial piezoelectric translation device for a scanning tunneling microscope},
    volume = {63},
    url = {http://link.aip.org/link/?RSI/63/263/1},
    number = {1},
    journal = {Review of Scientific Instruments},
    author = {N. Agraït},
    year = {1992},
    pages = {263--264}

    A thesis by R. Büchi from ETZ Zürich gives this - same behaviour:

    title = {Modellierung und Regelung von Impact Drives für Positionierungen im Nanometerbereich},
    url = {http://www.eek.ee.ethz.ch/publications/publication-18.html},
    school = {ETH Zürich},
    author = {Roland Büchi},
    year = {1996},
    keywords = {ems2009,model,quelle,stick-slip}

    I am using 1.0.7 with UTF-8 export enabled. When will this be solved? I have read on other threads that UTF-8 was not supported for BibTeX. However, even if it is not, there are better replacements for "illegal" characters than those currently used.

    Best regards,

  • You do not have the current version of the translator.

    However, the replacements you describe are the ISO-8859-1 encodings for those bytes. Are you sure that whatever program you are using to view the files is using UTF-8 encoding? (If you aren't comfortable with more advanced text editors, you can probably open the .bib file in firefox as text & manually set the encoding (view->characer encoding.))

    If your LaTeX+BibTeX installation is not setup to use UTF-8, do not use UTF-8 export. Non-UTF-8 export will replace those characters with their TeX entitites.
  • I clicked "Reset Translators and Styles" about two hours ago, I was expecting that to give me the current version of the translator.

    Your guess about the strange characters was right - I get "ü" as desired when I set Firefox to UTF-8. Thanks for your help. The "ü" and "ï" in the keys are still left out, however. Will that change with a more current translator?
  • As above, the latest translator is only in the not-yet-released 1.0.8 and the dev builds.

    Excluding UTF-8 from the entities is intentional and persists in the latest version of the translator--I don't know if there are any toolchains that actually accept UTF-8 keys or not. JabRef and other BibTeX-specific programs do not use UTF-8 in auto-generated keys.

    Some might find the use of the closest-matching lower ASCII character preferable to current behavior (e.g. 'u' for 'ü'). However, this obviously doesn't work for all UTF-8 characters & could not use the mapping tables already present in the extension. There are also larger discussions about changing the implementation of key generation (and/or retrieval), so perhaps we can think about what to do when that is implemented.
  • OK, I understood that.

    Probably it would be the beser to have an "entity" field in Zotero, allowing users to specify their own entities, using their preferred transcribtion of the characters in question.
  • edited November 10, 2008

    It seems this is the discussion with similar problems as the ones I experience. I have the same problem with one-page-papers as Greg describes above - but I cannot "fix" it because this simply are papers of only one page. So I'm looking forward to the solution in 1.0.8. Due to this I cannot use the export including UTF-8 encoding. (same error message as described above.)

    However I have still problems with the "Umlaut" encoding when I use the button "Save current collection in Bibtex format". If I do so the export works rather well but umlauts are encoded e.g. as \~{a} instead of \"{a} - and thus cannot be read correctly. However I'm unsure where I got this button from - is that from zotero itself are is that some piece of added software? So please excuse it I posted this here wrongly.

    best regards,

    PS: I think zotero is really good - thanks for your work!
  • Hello,

    I still have a problem with encodings. I hope, someone can help me.

    In the browser i have ISO-8859-1 and i cann read ö & ä. In the prefs of Zotero i have changed the input character to the same a my browser has - ISO-8859-1. Then during the export i have tried both, the ISO-8859-1 and the utf-8, but i cannot read my ö & ä - i see only �.

    As well I tried to change my input encoding to utf-8, but nothing changed.

    And I have got the "current version of the translator", also without any changes.

    So, what I'm doing wrong?

    With best regards,
  • It is not clear to me what you have done or how you are attempting to check the exported file. Here's what you should do:

    Copy-and-paste "ä" into a zotero field to ensure that you have a test records with a UTF-8 character in your database

    Gear icon->Preferences...->Export [tab]->Character Encoding: Check "Display character encoding option on export"

    Export to bibtex. Under translator options, if you select an encoding other than UTF-8 (such as "Western (ISO-8859-1)"), the ä will be transliterated as \"{a} & this should work with any version of bibtex just fine. If you select 'Unicode (UTF-8)', there will be no transliteration & the literal ä will be used. Assuming you use a UTF-8 capable program with a UTF-8 capable font & it correctly identifies the file, you should see 'ä'.
  • Thank you for the answer, but that was not my problem. If I go on a page with a ISO-8859-1 encoding, I can see my "ä" - but not in my Zotero, where I can only see this one: �.

    Hier is this page and you can test it: http://www.ub.uni-freiburg.de/xopac/wwwolix.cgi?db=ubfr&nd=30908828&VomOLAF=0&links=1&gk=&Aktion=S&isnListe=26372033,27916028,25445942,31024675,28762030,31178852,30908828,31249840,31250356,31176447,30584262,12142662,31308374,25450657,30308215,30340175,30820705,30584314,25428525,30576949&count=7&counter=0&anzeige=ti%3Deinf%FChrung+&treffer=24256&offset=1

    What shell I do with the preferenses?
  • Please don't hijack threads that do not pertain to your issue.

    Isolated pages will have this issue & it is best to report them as you encounter them. In this case, Library Catalog (X-OPAC).js imports the refman RIS formatted file & the server does not seem to use a standard character encoding correctly (try loading the saved RIS in firefox or a text editor).
  • //Please don't hijack threads that do not pertain to your issue.
    excuse me for this, it must be a translation problem

    if I understand correctly, the problem is not due to zotero, but on the javascript side. If I manually download the RIS, then I see this: ...hrung in die k”... in iso-8859-1 - so there is no solution, but to erase the js-bug...

    Thank you very much.
Sign In or Register to comment.