TypeError: oldIDs.map is not a function

I got (get) the following error when Zotero tries to upgrade the database.

TypeError: oldIDs.map is not a function

error report 593892982

I was trying to use firefox portable, so that I wouldn't have to create a new profile. Could that be the problem? I repaired the database just in case but got the same error message when trying to upgrade.

Also, the instructions say you should upgrade from Zoteo 1.07 ("of your existing Zotero 1.0.7 ") but this hasn't been released yet, has it? Is this a typo, or should I install the developer xpi before upgrading?

Regards, Jon.

OK, tried it with a new profile in firefox, same error: 2103924812
  • Fixed in the latest trunk build. Thanks.

    Obligatory note: The same data loss warning applies to the current trunk builds as the Sync Preview, only more so.
  • Hi Dan, installed the trunk build on a portable version and the database upgraded fine.
    I've got two copies of portable firefox installed (not disk space efficient but it means I don't have to worry about profiles or it doing anything to my work version of Zotero). 1 with the upgraded largish database, 2 with nothing but a couple of random new items added in. I can get 2 to upload to the server no problem but when I try to sync 1 I get no joy. I'm guessing the following error:

    <response version="1" timestamp="1215553847"><error type="malformed" code="INVALID_UPLOAD_DATA">Uploaded data not well-formed</error></response>

    is the reason why
    Given that this is being tested on a freshly repaired database, I'm stuck. Any ideas, short of deleting chunks to see if that fixes it?
  • Try the latest trunk build. I just committed a patch that strips characters invalid in XML when uploading the data. These will generally be invisible control characters from copied or imported text.
  • That seems to have been it. It wasn't liking "Ranciè€re" before and now it doesn't get stuck.
    Although I can sync from 2 to 1, I can't sync from 1 to 2. It doesn't seem to be throwing any errors. Its just not pulling any data down. Will try again tomorrow when I'm less tired.
    Thanks, Jon.
  • I had this issue too (reports 730404131, 874802583 and 1601601941). The latest trunk also fixes it for my database.
  • The trunk fixed this issue for me too.
This discussion has been closed.