Word 2010 can't find Zotero 4.0.12 for firefox in Palemoon 24.0.2(x64)

The Zotero toolbar is appearing in Word 2010 and the buttons are clickable albeit giving the standard communication breakdown message below.

'Word could not communicate with Zotero. Please ensure Firefox is running and try again.

Zotero is functioning perfectly in Palemoon but just won't communicate with Word 2010.

I've tried the troubleshooting suggestions and have deleted the zotero.dot file from Word startup,reinstalled the plug-in (Word Windows Integration 3.1.13) a few times to no avail. I don't use firefox and there's only one profile of Palemoon on board.

Any suggestions of how to get Word and Zotero communicating?
  • I've tried restarting too, no joy.
  • just to be clear - you have either executed or eliminated each of the four steps here:
    Also, you have re-installed from the cite tab of the preferences, not just by re-installing the add-on file?
  • I assume you have followed the instructions here: http://www.zotero.org/support/word_processor_plugin_troubleshooting#communication_error_or_non-responsive_plugin_buttons If you have security software other than ZoneAlarm, you may want to disable that too.

    If none of that was helpful, this could be a Pale Moon issue, which I don't think is going to be officially supported by Zotero devs. You can try to figure out if this is the case by (1) creating a fresh Pale Moon profile and installing Zotero and (2) installing Firefox (for testing purposes) and installing Zotero there. If (2) but not (1) fixes it, then it's probably Pale Moon.
  • edited October 6, 2013
    Hi guys,

    Cheers for the speedy responses.

    I have tried the all the steps listed in the linked troubleshooting thread and updated from the cite tab of preferences as well as through add-ons in Pale Moon with no success, unfortunately.


    It seems you're right about this being a potential Pale Moon issue. I installed Firefox, added Zotero for Firefox and it's communicating fine with Word 2010.

    I tried a fresh profile of Pale Moon but it's still failing to communicate with Word.I've also re-installed Pale Moon over the existing installation hoping that this might patch anything that might have gone awry but still no luck. ):

    Any other suggestions?
  • edited October 6, 2013
    I think I figured it out (and also found an old post about this https://forums.zotero.org/discussion/16933/). I don't know what Simon's policy would be on officially supporting some of these more popular Firefox forks, but you can fix this yourself as follows (not tested, but I think this is right):
    1. Locate your zotero.dot file

    2. Open it in Word, go to View -> Macros -> View Macros (this may vary based on Word version). Select one of the macros from the list (something like ZoteroInsertCitation) and click Edit.

    3. In the window that opens up, find the line that starts with "Sub ZoteroCommand". Below you will find the following lines: ' Try various names for Firefox
      Dim appNames(5)
      appNames(1) = "Zotero"
      appNames(2) = "Firefox"
      appNames(3) = "Browser"
      appNames(4) = "Minefield"
      For i = 1 To 4

    4. Change this to read: ' Try various names for Firefox
      Dim appNames(5)
      appNames(1) = "Zotero"
      appNames(2) = "Firefox"
      appNames(3) = "Browser"
      appNames(4) = "Minefield"
      appNames(5) = "Pale Moon"
      For i = 1 To 5
      Note that there are 2 changes: add one line and 4 to 5

    5. Save everything and restart Word.
    The space in the "Pale Moon" is a bit suspicious to me, but I took it from the patch in the old thread, so it may be right.

    Edit: edited the patch slightly
  • edited October 7, 2013
    Hi Aurimas,

    Cheers for this. I tried the changes in the macro but no joy.

    I tried a couple of times, once with a space and once without a space (I.e appNames(5) = "Pale Moon"
    appNames(5) = "Palemoon") but neither did the trick.

    I posted this problem over in the Pale Moon forum subsequent to your previous suggestions when this appeared to be a Pale Moon issue.

    It turns out it's likely a communication problem between Pale Moon(64 bit) and Word 2010 (32 bit).


    I'm going to try with the x86 version of Pale Moon, so your changes to the macro may not go to waste if the problem persists!

    Thanks a lot for your help!

  • edited October 7, 2013
    A couple of developments. Firstly

    I installed the x86 version of Pale Moon. Without changing the macro, the problem persists, i.e 'Word could not communicate with Zotero'.

    Adding to the macro as Aurimas suggests above gets things working :)

    appNames(5) = "Pale Moon"
    For i = 1 To 5

    I then tried the x64 version of Pale Moon, just out of curiosity.

    It turns out the error message is different after changing the macro. It seems to still stall at the 32 bit 64 bit divide, but a little closer to the gap.

    'Zotero could not load the component required to communicate with your word processor. Please ensure the appropriate extension is installed and try again.'

    It'd be great if the macro could be updated to include the Pale Moon patch so that the x86 version of Pale Moon and Word can communicate as they are now doing for me.

    Everything seems fine so far but I've yet to road-test the current set-up to discover any other issues. I'm happy to test and report back if that helps anyone inclined towards creating an official Pale Moon friendly zotero.dot file. I'd love to have a go but this capability lies far outside my very limited areas of expertise!

    Is there an official line on maintaining compatibility with Firefox variants like Pale Moon?

    Thanks again Aurimas.
Sign In or Register to comment.