Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

  1.  
    Attempting to backup, I lost all data. Using Search I found the files on the C Drive. When I attempt to import the file to zotero, an error message calls for a translator.
    • CommentAuthorTjowens
    • CommentTimeJun 10th 2008
     
    To reinitiate your Zotero collection from the zotero.sqlite.bak file follow these steps.

    1. Locate your Zotero directory

    2. If there is an existing zotero.sqlite file remove it (First make sure that it is smaller than the zotero.sqlite.bak)

    3. Rename zotero.sqlite.bak to zotero.sqlite

    4. Start up Firefox and you should have loaded up your back up collection.
  2.  
    Thanks - but after a couple of hours, I'm unable to locate the Zotero directory. I've tried the move of opening hidden files, but zotero is not there. I've tried renaming the zotero.sqlite.bak file, but while the file is then named zotero.sqlite it remains a bak file.

    Can it be that my file is of an earlier version of Zotero, and the current version willnot accept an older file?

    Thanks again,

    Bill Robinson
    • CommentAuthorTjowens
    • CommentTimeJun 11th 2008
     
    The easiest way to find your Zotero directory is to click the "Show Data Directory" button, which you can find in the advanced tab of your Zotero preference pane. To open the preferences pane click the gear icon, this will open the actions dropdown menu. Select preferences from that dropdown menu. If you use this method, be sure to close Firefox before you move or rename any of the sqlite files.

    I am not sure about your issue with renaming the .bak file. Are you saying that when you edit the name the file just refuses to change? If you have not dealt with the existing zotero.sqlite file and both the zotero.sqlite and zotero.sqlite.bak files are in the same directory you would not be able to rename the files the same thing. So make sure you have removed the existing database before your rename the .bak file.
  3.  
    Again, many thanks,

    I have located the Zotero directory in the way you said to. I get a yellow file folder called Storage (3.48 MB) along with two shortcut files - one named zotero.sqlite (a few KB) and one named zotero.sqlite.bak (same no. of KB)

    After delelting everything except the .bak file I have tried to rename it - but it insisits on keeping its .bak status. atempting to open it yields an opportunity to open w/ Firefox, clicking to do so yields a repeat of the same opportunity.

    I was able to import the .bak file, but was unable to open it or do anything with it other than seeing it in the Library colum.

    I have a copy of the copy, so I assume all is not yet lost. My Collection is small, but represents a good sized number of saved "quotes" from many authors.

    Hope you can help further, I do appreciate your responses.

    Cheers, Bill Robinson
    • CommentAuthorPhattieM
    • CommentTimeJun 11th 2008
     
    I'm not sure how the file extension refuses to change. Under folder options, do you have show known and unknown extensions highlighted?
  4.  
    Do you mean folder options - as in Control Panel or someplace esle?
  5.  
    Do you mean folder options - as in Control Panel or someplace esle?

    Assuming this is XP, in Explorer (a.k.a. My Computer), Tools menu, Folder Options..., View, Advanced Settings, make sure "Hide extensions for known file types" is unchecked.
  6.  
    Greetings Dan,

    Hide extensions etc is unchecked. So far the solutions suggested by your colleagues haven't worked. When I try to open zotero.sqlite, the message is "Windows cannot find etc. - make sure you have spelled correctly etc." Hope you have some ideas.

    Cheers, Bill Robinson
  7.  
    Zotero looks for zotero.sqlite when it starts up. That's the only way to "open" a database in Zotero. Double-clicking on it from Explorer will not work.

    So, one way or another, you'll need to rename zotero.sqlite.bak to zotero.sqlite. And make sure you have a copy of the .bak file, since Zotero will overwrite zotero.sqlite.bak when it exits.
  8.  
    Thanks Dan,

    When I reach the Zotero Data Directory it has three items: A file folder "Storage" and two icons, zotero.sqlite and zotero.sqlite.bak. When I delele sq.lite and rename the bak file as zotero.sqlite. and then bring up Fireox and Zotero, all I get is the Zotero quick start guide in the center column.

    I have been able to import the sqlite file into the left and center colums as zotero.sqlite - but then can do nothing with it.

    Thge local Geek squad says the "executable JAR file, which I brought to them on a CD, was corrupted, but that the samller zotero.sqlite.bak file, which I brought on another CD, was not read by the current version of Zotero. He suggested that I remove Firefox, go to Zotero.com, and find an earlier version and download that.

    Any merit to that plan?

    I have tried to use the Data base repair tool, but I can't get the file into the tool.

    Thanks for sticking with me.

    Cheers, Bill Robinson
  9.  
    1) Make a backup of the Zotero data directory.

    2) Assuming the zotero.sqlite.bak from your CD contains your data, copy that into the Zotero data directory, remove zotero.sqlite, and rename the zotero.sqlite.bak that you copied in to zotero.sqlite. Start Firefox.

    Again, Zotero just looks for zotero.sqlite when it starts up. You'll need to figure out which copy of zotero.sqlite or zotero.sqlite.bak you have (if any) contains your data. Good rule of thumb: go for the one with the biggest file size.

    Can't really help you much beyond that.
  10.  
    Thanks for our help Dan, and thanks to your colleagues.

    Although there are zotero files on my C Drive, I can't recover them. Somehow, attempting to back-up, I did something that corrupted them and made them unreadable.

    I have downloaded Firefox 3, and will start all over again. Fortunately I have some of the notes that I had put in Zotero, and my research was in early stages.

    Cheers, Bill Robinson
  11.  
    Dan,

    I am pleased to report that I got it all back, using the advice I received from you and your colleagues, but this time by erasing every last vestige of what was on my C Drive. Apparently I had tried so often that I had left a trail of sqlite files that were nothing but records of failed attempts.

    I started all over again using my wife's computer ( which had never heard of Zotero) and followed instructions. It worked. And then, of course, I was able to replicate the event on my computer, and I'm home free. Hours and hours of work saved.

    It is a great, great program.

    Cheers, Bill Robinson

Zotero Forums are powered by Vanilla 1.1.5a