Imports are extremely slow (or freezing)


I am trying to import Ris files that I exported from Scopus into Zotero standalone. When I do, the "importing items" status bar appears and fills up a little and then stops. I let this run for over 3hrs last night and it did not change. The Ris file that I was trying to import contain only 29 citations. I also tried to import on different networks (at work and at home) and the same thing happened.

Is there anything that I can do to get the importing function to work again? I followed the Troubleshooting tips from "Documentation" and this problem is still occurring.

I should mention as well that when I first downloaded Zotero, about 1.5 months ago, I imported Ris files (that I exported from Web of Science) with no problem. My library is currently at 7359 items, could this be part of the problem?


  • There appear to be repeated attempts from your account to download all of your data in all of your libraries from the server. Make sure you're fully in sync before proceeding.
  • Hi Dan,

    I am not sure what you mean. Do you mean that my account is attempting to sync my library online and is failing?

    Whenever I open Zotero, the app freezes and a status bar box with "Processing updated data from sync server" is above the status bar. This happens every time I open Zotero standalone and Zotero for Firefox. Is this what you are referring to? I just checked and my the number of items in my online library is less than what I have in Zotero standalone.

    Will fixing this sync problem allow me to import Ris files? And what can be done to fix a broken sync?

  • Update: I did a manual sync and fixed all the "conflict resolutions" and now my online and desktop library match. I attempted to import another Ris file (again with 29 citations) and it is still not working. I can import smaller files, i.e. one citation.

  • OK, good. So now you'll need to find the problematic entry in that file, which you can do very quickly with a "binary search". Open the RIS file in a text editor and divide it in half, and then try importing each half. For the half that fails, divide it in half and try importing each half. Repeat that a handful of times and you should be able to identify the entry that's causing it to fail. If you could then post that entry here, we can tell you the problem.

    Alternatively, you can send the RIS file to with a link to this thread, but there's a good chance we won't be able to reproduce the problem, particularly if it has attached files.
  • Hi Dan,

    I did the binary search and I was able to import all the citations when the number of items in the file was 5. There was one set of 5 that would not import as a group but did import individually (I tried to post the text here but went over the character limit).

    The first things that I imported into Zotero were Ris files that I exported from my Web EndNote and those worked fine (even large files with 544 citations). I tried to import the same files again and it did not work (the file I tried contained 198 citations).


  • Can you email the file with 5 references that fails to, with a link to this thread?
  • Actually, I'm pretty sure this is going to be a problem we've seen before but haven't been able to reproduce ourselves ("Cannot start a DB transaction from a different wait level").

    We'll see if we can do anything about this for 4.0.10. Since we're not able to reproduce this, it's likely something particular on your system that's triggering it—some way you have Zotero configured, having auto-sync on or off, having something open or closed (e.g., the tag selector), where the mouse is positioned on the screen, etc. If you can find any pattern for when this occurs or doesn't occur, that'd be helpful. (It could also just depend on the speed of your computer.)
  • I have sent the e-mail.

    Is there any additional information that you need? Could this be a problem with my computer or network rather then the references themselves?

    Thanks for all your help so far!

  • You should also check your database integrity from the Advanced -> Files and Folders pane of the Zotero preferences, though it's probably fine.
  • (As expected, those five import fine for me.)
  • Hi Dan,

    I checked the database integrity and it is fine.

    I went to another computer and am able to import large files into an empty Zotero library. I was wondering, if I set up Zotero on a second computer, import the files that I need, and then sync to my library, will this add to or replace my previous library. Or should I sync first to my current library (on the second computer) and then try and import the new files.


  • Either order is fine. It will just merge the two libraries. But generally speaking, it's better to be fully in sync before making changes.
Sign In or Register to comment.