IEEE Xplore error: "Permission denied to get property HTMLDocument.evaluate"

I can't save any IEEE articles to the Zotero database. When I run the translator in Scaffold (on any article: try for an example) I get the following error:

07:19:21 Translation using IEEE Xplore failed:
thrown exception => Permission denied to get property HTMLDocument.evaluate
url =>
extensions.zotero.cacheTranslatorData => true
extensions.zotero.downloadAssociatedFiles => true

I'm running Zotero 1.0.4 and Firefox on Windows Vista. Everything was working fine before I upgraded to Zotero 1.0.4 yesterday. I can save articles from other websites (such as ACM). This looks like some kind of XPath error? Can anyone else confirm it? Let me know if I can do more to help debug.
  • Works for me.
  • I have the same problem. It also started after upgrading to version 1.0.4. I'm also using Vista. I detected the problem in IEEE but also in DSpace (try
  • I thought it might be something with my Firefox profile, so I created a clean profile with only Zotero 1.0.4 installed and I get the same problem.

    I rolled my main profile back to 1.0.3 which works fine. I can still test with 1.0.4 on my other clean profile, so let me know if there's something clever I can do to track down the problem.
  • edited May 19, 2008
    If you're experiencing new translator errors in 1.0.4, could you try installing this XPI over your current version?

    It reverts a one-line change that we made for Fx3 compatibility when using Firefox 2, and otherwise is identical to 1.0.4.

    We think that change is the cause of these errors, though we can't reproduce them and don't know why they're occurring.

    Another alternative would be to try 1.0.4 in Firefox 3, as this problem doesn't seem to exist in Firefox 3. If you're not sure if you want to move to Firefox 3 yet, it's safer to test in a clean profile.

    Also note that this test build will offer 1.0.4 as an upgrade, which, if the build actually fixes the problem, you wouldn't want to accept until we push out a new release.
  • In my case the xpi you sent solved the problem. Thanks a lot!
  • We're trying to get a bit more info on this (and trying to see if it happens in Fx3). If you are (or were before the test build) experiencing this, what other Firefox extensions do you have installed?
  • My Firefox has version

    I created a new profile, without extensions. The problem remained. In the extras menu, I realized a few plugins were still there. I disabled them one by one. The problem was caused by the "RealPlayer Browser Record Plugin". Disabling it alone solved the problem in the clean profile.

    Back to my old profile, I disabled the RealPlayer plugin and updated zotero, which brought me back to the proper 1.0.4 version. I updated it again, and it produced a message mentioning some compatibility update (?).

    After this, I believe I have the regular version o Zotero 1.0.4 running, and the problems with DSpace and IEEE disappeared.
  • The problem was caused by the "RealPlayer Browser Record Plugin". Disabling it alone solved the problem in the clean profile.
    Yup, that's it. Reproduced here after installing RealPlayer 11 with that option enabled. According to Mozilla's Problematic Extensions page, that extension causes all sorts of problems, so disabling it is probably a good idea anyway. Thanks for the detective work.

    (Just to clarify for anyone stumbling upon this thread, the "RealPlayer Browser Record Plugin" extension is different from the RealPlayer plugin that lets you listen to embedded Real content.)

    The Browser Record extension (thankfully) isn't yet compatible with Fx3, but the problem doesn't seem to happen in Fx3 even if I force the install (which is good, since the change we reverted for Fx2 in the loadtest build above is required for Fx3 compatibility).

    We may release a new version very soon that reverts this change for Fx2.
  • Interesting- I don't have the "RealPlayer Browser Record Plugin" installed because I don't have RealPlayer 11 installed. I do, however, have Real Alternative installed. There's nothing marked by Real in my extensions list. In my about:plugins I see "RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)" and "RealPlayer Version Plugin", if those are relevant. Would these cause the same problems?

    FYI your modified xpi solved the issue for me on my machine as well.
  • I don't have the "RealPlayer Browser Record Plugin" installed because I don't have RealPlayer 11 installed
    Hmph. Do you have any other extensions installed by default in your clean profile?
  • The three extensions installed by default when creating a new profile are DOM Inspector, Talkbalk and Google Gears. I disabled all three in my clean profile and I still get the same error. I also tried to temporarily empty my \plugins directory but that doesn't help either. So the issue for me is coming from somewhere else?
  • So the issue for me is coming from somewhere else?
    I'd be interested to know if you get the same behavior in a clean profile using Firefox 3. Before MMSequeira narrowed this down to the Real extension, I considered that this might be due to some sort of race condition dependent on computer speed or connection speed—and it's not inconceivable that the Real extension could just expose such a condition. But regardless, if it worked for you in Firefox 3, I'd be pretty confident that using the old method in Fx2 and the new method in Fx3 would do the trick.
  • I am having the same "Could not save item issue" with Zotero 1.0.4 on the following website: - I tried the 1.0.4-loadtest.xpi as well, but it did not fix the problem. I am running Fx2, no Real extension, but I am running the NoScript extension - could that be the problem? Thanks.
  • I'm having the same problem with FF3 RC1 and saving references from Google Scholar.
  • I'm running Firefox with Zotero 1.0.4 and also had a "Could Not Save Item" error, but on Google Books. If it's useful the particular URL is:,M1
  • Dan I installed your XPI,
    and I can save the book now fine.

  • I'm running Firefox with Zotero 1.0.4, and I received a "could not save item" message on LexisNexis. The specific URL is:

    I installed, but that didn't help. Thanks!
  • 1.0.5 is now out with the loadtest fix, which should fix the "Permission denied" errors. Other translator errors are unrelated.
  • Hi Guys,

    Could you please help me to fix the error "Could not save item" when I try to save an article from springer to my Zotero run by firefox in windows 8?

    Thank you very much
  • Chau Vu: Start a new thread, and include a sample URL and Report ID. This thread is ancient.
This discussion has been closed.