Word and OO plugin crash (Zotero kills Word cont.)


this post is related to Zotero Kills Word discussion but now I've got more info that might help sorting out the problem and it is not related only to Word.

I guess it all started when I tried to open a Word file with Zotero references from my friend without having those references in my Zotero database.

Ever since then when I try to use Word plugin, my Word freezes and needs to be killed. So I've installed OpenOffice Beta3 to see if I can get any further and voilá, I got an error in function fnGetPropterty (sProptery=ZOTERO_PREF) reading com.sun.star.beans.UnknownPropertyExceptionPlease see the complete screenshot (PNG, 30kB).

Any help or advice is much appreciated since I really need to work with Zotero urgently (localization and implementation of ISO are my current projects).
(Here is the current version information - I've upgraded to FF3 and dev. version of Zotero in hope problem gets fixed): Widnows Vista SP1, Firefox 3b5, Zotero 1.0.4.r2691, MS Word 2008 SP1, OOo-dev 3.0.0 Beta and MS Word/OO Integration 1.0b3)
  • Could you check the Custom tab of the File->Document Properties dialog in Word to check if that property exists and what its value is?
  • I checked the Document Properties dialog - Custom tab, there are no custom properties set... the list is blank.
  • OK, it is almost a month I am trying to make Zotero plugins in Word or OpenOffice work on my computer in every possible way. Since this forum is not guiding me anywhere, I have an honest question - is there a platform, place, anything where I can ask an receive some more suggestions about how to address this issue. I mean, it is an issue - Zotero Word plugin freezes the app instantly. OO ends with an error... how can I go around this. Where or Who I can ask for advice?

    Please, drop a word! Thank you!
  • 1) Just looked at your version info again. I don't think the OO plugin works in OO3 at all, so that error message may not be particularly meaningful. Have you tried OpenOffice 2.4?

    2) This happens in new documents?
  • Hi Dan,

    thanks for your response. I've uninstalled OO3 and installed OO2.4. Now the application mimics the behavior of MS Word - it just stops responding when I try to Insert citation or Set Doc preferences, Refresh, etc. It however responds correctly (in both programs) when I try to edit citation or bibliography outside the field by telling me I must place cursor within one.

    Yes, this happens in new documents (and every document as well). As I said, since this happened for the first time, I've re-installed Zotero, then deleted database, then uninstalled Firefox itself and every trace of it I could find in the profile folder and registers... something is handing in the air between Zotero and the plugins, but where to find it... You think re-installing Office might help?

    Thanks for helping me!

    (I used OO only out of curiosity when I was trying to locate the problem, no one uses it here unfortunately.)
  • Can you provide debug output from starting up Firefox to when you first click one of the Zotero buttons in Word?
  • Yes, but nothing happens in console when I click Zotero buttons in Word.
    Here is the debug - http://www.cardioplus.sk/files/debug1.txt
  • edited May 22, 2008
    zotero(3): Not initializing integration HTTP
    Something is stopping Zotero from binding to the integration port (port 50001).

    Close Firefox, and then look for other firefox.exe processes in the process list. (If there are any, kill them.) Failing that, restart your computer and then try again (with debug output).

    Also discussed here: http://forums.zotero.org/discussion/2984/
  • And here is another, more wordy, this happens when I click Zotero icon. But again, no action in console after I click button in Word.
  • Also worth mentioning is that, if you use multiple accounts on your computer and leave Firefox/Zotero open on one, it'll probably appear to hang if you use the Word plugin on another. I haven't tested this, but it's possible that it would even pop up the Add Citation dialog on the other account, which would make it look like Word had hung.
  • I've restarted and got the same thing.
    This is a single account machine but your note is correct, when I was working on some other computer helping my friend, we got into situation when Add Citation dialog was actually poping up on the other account.

    I remember now that I was briefly using BitDefender around the time when Zotero stopped working for me. However, I don't use it anymore. Could disabling the firewall help? I am going to disable SpyBot Teatimer protection to see if that is the problem.
  • Could disabling the firewall help?
    A firewall shouldn't really prevent binding to a port, just access to it. But turn off anything you think might prevent Zotero from binding to a network port. It's also possible Vista has some security feature that's blocking this.

    The rest of the debug output doesn't matter. Until you can get rid of the "Not initializing integration HTTP" message, it won't work.
  • I've tried disabling everything. I have even created a new account, restared and tried it there, but still the same line. The last thing comes to my mind it that it can be Office 2008-SP1 related thing but from this is looks the problem is within the OS itself. I have to leave the office now (midnight here), but will try to continue looking into it from home. Thanks for the help so far!
  • I left Word frozen for almost an hour and patience paid off... I got the same error as discussed in http://forums.zotero.org/discussion/2984/
    "An error occurred communicating with Zotero. Please ensure Firefox
    is open and try again."
    which I guess was to be expected. However, log out and log in does not help...
  • That's just a timeout. If Zotero didn't bind to the port at startup (which you would see in the debug output), there's nothing to wait for.
  • I was still unable to resolve the problem. Please, do you have any suggestions about the tools I can use to try find out what is stealing port 50001 from Zotero... like some sniffer that will list open and closed ports or I don't know what can help. Or anything that can help me to move on. I really do not want to go into reinstalling otherwise smoothly set-up system. Any suggestion is greatly appreciated!
  • Hi Dan (and joephir),

    I've identified the problem - who is sitting on port 50001, but now my question is - can't be Zotero forced somehow to use a different port? Cause those things that are using 50001 on my computer seem to be quite important:
    Security Center, TCP/IP NetBIOS Helper, Win Event Log, DHCP Client and at last but not at least Windows Audio.

    Sometimes it is enough to stop Security Center service and kill the associated process and Zotero springs to life, however, the other time it really kills everything mentioned above along the way so you end up not only without security nags and music. However, this needs to be done after each restart...

    Here is the screen showing my port binding and associated Services. I'd appreciate if you could please take a quick look at it and tell me what do you think I can do about it.

    And here is the link to the free tool I used to analyze the system - if you are interested that is.

  • Can you verify that 50001 is in use after restarting and before you first start Firefox/Word? Would be helpful to know if other people are experiencing this as well.

    If you want/need to use a different port, the port used on the Zotero side is now customizable via about:config in the latest dev build (and will be in 1.0.5, which should be out very soon). The pref is extensions.zotero.integration.port.

    On the plugin side, you'll have to open up Zotero.dot in Word (Enable Macros), open Visual Basic Editor under Tools->Macro, and search for 50001 in the code. Replace that with the port you set in Firefox and resave the template.

    Make sure you've restarted both Firefox and Word, and you should be set.
  • Yes, 50001 is in use immediately after restart. I've tried it several times. Restarted, checked the ports, killed the service, opened FFox and let Zotero grab the port, which it did. Then restarted the service after which it settled on different port. I was trying to teach my compter a "lesson", however to no avail. After I restarted computer, security center and others again stuck with 50001.
    But several weeks ago everything ran smoothly. Must have been an update, or maybe Bitdefender reorganized my ports, or just a stupid coincidence. I don't know. I am going to try to alter the ports with the dev build now :-)
  • And it works! Thanks Dan for spending your time!
  • I also had this problem. I think in my case it was due to a different cause though. I have my zotero library located on a flash drive, so I can take it to all the computers I work on. I tried to start word (2002) at one point while the flash drive was not in. After that it crashed when I tried to enter a citation

    There was nothing else using my 50001 port, but it still didn't work. I tried reinstalling the plugin, restarting, that didn't work. I think I have solved the problem. I deleted the plugin from C:\Documents and Settings\User\Application Data\Microsoft\Word\STARTUP. I restarted, reinstalled Zotero (with flash drive in) and then reinstalled the plugin. That seemed to fix the problem, though I have no idea why.... I am glad I didn't have to get into the mess of reassigning the port discussed above since I am kind of a novice at this...
  • Hello,
    I have exactly the same problem as athelas. Running Vista + OO 2.4 and Word 2007, I installed Zotero plug-ins yesterday, and it doesn't work. Both OO and Word freeze when I click on any item of the Zotero toolbar, and I have to kill them (I don't get any error message). I tried the Zotero debug, nothing happens. I looked for the 50001 port problem: I am exactly in the same case as athelas, but when I tried changing ports, nothing happened either.
    Any suggestion?
Sign In or Register to comment.