Webdav syncing, new computer, no downloading

I got a whole new laptop, win 7 64 bits. Zotero 4.0 installed, account, password, webdav file syncing all set, verification passed, clicked green syncing icon, but only zotero server sync happened, leaving me a right list of entries but not a single attachment. No errors were popped, nothing happened.
I tried to catch a new pdf from a website, it's uploading to "my library" on the top-right processing bar, but downloading is none.
I have synced two computers, one old laptop and a pc, but this new one, I failed.

I want to know what happened. Can anybody help me?
  • In general, see Files Not Syncing.

    First, though, try the latest 4.0 Branch dev XPI. There's a bug in 4.0.4 that's preventing certain file sync errors from showing up. You may need to do a Reset File Sync History (or add a file from another computer) to trigger the redownload with that.
  • Thank you Dan. I tried to Reset or add a file. Again, the uploading and the entries syncing are good, but no automated downloading.
    But I found that when I right click an item to "view PDF", it's actually beginning to download. I think it's not retrieving a new pdf file from the internet because the processing bar flows.
  • Did you try the branch XPI? Sorry if I was unclear—I meant that you might need to do Reset File Sync History or add a file with the branch XPI.

    In the Sync pane of the Zotero preferences, do you have file syncing for that library set to "as needed" or "at sync time"?
  • Oh, unless you're using Standalone, in which case you'd either have to try the branch XPI In Firefox (which will share your existing data directory by default—you just need to close Standalone first to use it) or wait for 4.0.5, which will probably be out later today.
  • Thank you very much, Dan. I installed branch XPI, but I'm not clear how to "add a file with the branch XPI". Do you mean to add one object from a website while having branch XPI installed?
    I'm not using standalone.
    It's not yet syncing my pdf database. My library is not a small one I think, it's about 2.2G. Could this be a network problem?
  • Do you mean to add one object from a website while having branch XPI installed?
    yes, to trigger syncing.
  • edited April 13, 2013
    No, I meant add a file from another computer, sync that computer, and then sync with the branch XPI on this computer. You need to trigger file sync downloading, but Zotero skips the download step of file syncing if the last-sync time on the WebDAV server hasn't changed, and it updates the last-sync time after uploading a file. So you can either add a file from another computer or just do Reset File Sync History from the Sync->Reset pane of the Zotero preferences, which ignores the last-sync time.
  • edited April 15, 2013
    Same problem as arthurwyy here. I use Zotero for Firefox in Fedora 18 and Windows 8, and cloudme.com for webdav syncing of attachments. I already installed the branch XPI (4.0.5.r11263), already reset File Sync History in both systems, already added one object using the branch XPI, but still can't get Zotero to download attachments. There's no error message. Uploading works fine (webdav settings are working and cloudme.com server is getting all the files), the library syncs well, attachments in group libraries sync perfectly using Zotero storage. I don't know what could be the problem.
  • edited April 15, 2013
    Same here. I use Zotero Standalone in iMac/Mountain Lion and Laptop/Windows 8, and Cloudme for webdav syncing of files.
    I followed your instructions as well but nothing happened. Exaclty the same behaviour as erjimenezpe. I can get the files from cloud.me, but they do not sync with my laptop.
  • See Files Not Syncing. If it's not working for you with the branch XPI, we need a Debug ID as explained there.
  • Hello Dan.
    Debug ID: D138679036 for an attempt to reset sync. Already submitted
  • arthurwyy: You appear to have submitted that in the middle of the sync process. For it to be useful, the debug output needs to include the entire first sync—until the sync icon stops spinning—after Reset File Sync History and an attempt to open a missing file, as explained at the bottom of the Files Not Syncing page.
  • Also, what's the timestamp for the zotero/lastsync file on your WebDAV server (assuming the file exists)?
  • Thank you Dan. I have a new ID D908647050. Every time I reset history and sync again, I find it uploading 27 files. The timestamp is 2013-04-16 12:41.
  • I believe this is an issue with cloudme.com:

    (3)(+0000000): HTTP PUT https://webdav.cloudme.com/[...]/zotero/lastsync


    (3)(+0000001): HTTP GET https://webdav.cloudme.com/[...]/zotero/lastsync

    (3)(+0000390): HTTP GET https://webdav.cloudme.com/[...]/zotero/lastsync
    succeeded with 200

    (3)(+0000001): Last successful WebDAV sync was Thu Jan 01 1970 08:00:00 GMT+0800

    The server appears to be returning an incorrect date for the file that Zotero uses to track the last time a file was uploaded (in order to know whether it should bother downloading new files).

    Could you load that URL (replacing the stuff I stripped out) in your browser, view the page info, and look at the modification time? (In Firefox this is Tools -> Page Info and the "Modified" field—the process will differ slightly in other browsers.)

    Alternatively (or in addition), you can download the latest 4.0 Branch dev XPI and generate another Debug ID for a regular sync (no need for a reset), which will include that information. (If you do this, make sure you get version 4.0.5.r11266 or later. If not you may need to clear your cache in Firefox.)
  • But the timestamp for that file seems to be the time I sync when I see it on cloudme.com. I've got the version 4.0.5.r11266 now. And this is my ID D277032557. Thank you for your effort Dan.
  • edited April 16, 2013
    Actually, that Page Info part was a bad test—in the absence of the Last-Modified header, I think that just shows the contents of the Date header, which should be the time at which the page was loaded. Are you sure you're seeing the sync time and not just the time you loaded the page? If so, I suspect cloudme.com is just returning the last-modified time in the wrong header. According to your latest debug output, the Last-Modified header appears to be empty.

    If you want to confirm that that's the case and that this isn't an issue in Zotero, you can install the Live HTTP Headers extension, open it from the Tools menu, and then load the lastsync URL. You should see a request section (with a "GET" followed by the lastsync path) and a response section ("HTTP/1.1 200 OK") immediately below it. I'd be curious to know the values from the response section of the Date header and, if it's there, the Last-Modified header, and how they compare to the lastsync file's timestamp as you see it on the server.
  • I want to confirm that there is a problem with the attachments in webdav server. They are not downloaded. The only way to work is to put the "Download files" option to "as needed". In that case it works but it is not convenient if you have a big library.
  • I forgot to refer that I use box.com
  • igd: I'd need the same info from you as from arthurwyy—a Debug ID for a sync attempt using the latest 4.0 Branch dev XPI, as well as (ideally) the info from Live HTTP Headers that I request above.
  • D390660925
  • (3)(+0000000): Last successful WebDAV sync was Thu Jan 01 1970 01:00:00 GMT+0100
    Same issue as arthurwyy, so I'd need the info from Live HTTP Headers.
  • edited April 16, 2013
    GET /[...]/Documents/zotero/lastsync HTTP/1.1
    Host: webdav.cloudme.com
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-US,en;q=0.5
    Accept-Encoding: gzip, deflate
    Connection: keep-alive
    HTTP/1.1 200 OK
    Server: nginx/1.1.19
    Date: Wed, 17 Apr 2013 01:36:00 GMT
    Content-Type: text/plain;charset=UTF-8
    Content-Length: 0
    Connection: close

    Hello, Dan.
    This is the value from HTTP header, wed, 17 Apr 2013 01:36:00 GMT
    Then I opened folder on cloudme.com, the lastsync is 2013-04-17 09:49.
    BTW, I'm in China, cloudme.com seems to be providing my local time, and http header a GMT time. Seems that this is right, because, I opened cloudme.com minutes later.
    I don't know, kind of confused.
  • igd is right, as I said, I can trigger downloading if I set it as needed and click view pdf.
  • OK, so it looks like this is indeed broken on cloudme.com's end (and perhaps box.com's as well). They're not returning a Last-Modified header for that file, which Zotero relies on to determine whether to try to download new files.

    I've worked around this in the latest 4.0 Branch dev XPI, changing the way Zotero determines whether WebDAV file downloading is necessary. If you could install that XPI, do a Reset File Sync History from the Sync->Reset pane of the preferences (or, alternatively, upload a file from another synced computer), and sync again, Zotero should start downloading files again. This fix will be included in 4.0.6, at which point you should switch back to that. (You can also leave Zotero in download-as-needed mode until 4.0.6 comes out.)
  • Latest 4.0 branch dev xpi installed, file sync history reset, and sync, my zotero finally began to download from webdav of cloudme.com.
    Lots of lots of thanks to Dan Stillman, and zotero.
    Been using zotero for about a year, never found a better bibliography management solution.
    Thank you so much, Dan.
  • OK, great. Thanks for your help debugging this. When 4.0.6 comes out (which should be within a day or two), remember to switch back to that.
  • 4.0.6 is now out with this fix. If you're using the dev build, you should switch back.
  • Great! Seems to be working properly now. Thanks a lot for all your nice work!
  • I confirm it works with box.com too! Thanx
Sign In or Register to comment.