Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013 edited
     
    Before this problem occured it was saving just fine into the subfolder I had created as indicated by the ballon that pops up on top of the zotero logo in the task bar. However, now when I click the icon in the address bar to automatically import citations into zotero, it says that it is saving into the parent folder ("My Library") and the ballon hangs there for a long time. When I check all folders the citation was not added to the collection.

    I am using this without creating an account and it was working just fine in that offline manner. I created an account with zotero so I can post my problem here. Does anyont think that trying to sync zotero with my new account may help? Any suggestions would be appreciated.
  1.  
    Can you provide a Report ID for this?
  2.  
    Also, an example URL where this happens (even if it's everywhere) would be helpful.
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013 edited
     
    It is happening at all webpages but here is an example of a webpage containing a citation on Pubmed on which zotero is giving this problem:

    https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3148732/

    Report ID:615951465 (the pasted error report is much shorter than the whole report because of the character limitation for posts; how shall I post the entire report?)

    [JavaScript Error: "[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165" data: no]" {file: "chrome://browser/content/tabbrowser.xml" line: 404}]

    [JavaScript Error: "collusion: DEPRECATED: require("private-browsing").isActive is deprecated.
    Traceback (most recent call last):
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/deprecated/events.js", line 123, in _emit
    return this._emitOnObject.apply(this, args);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/deprecated/events.js", line 153, in _emitOnObject
    listener.apply(targetObj, params);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/content/worker.js", line 230, in portEmit
    self._addonWorker._onContentScriptEvent.apply(self._addonWorker, arguments);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/content/worker.js", line 603, in _onContentScriptEvent
    this._port._emit.apply(this._port, arguments);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/deprecated/events.js", line 123, in _emit
    return this._emitOnObject.apply(this, args);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/deprecated/events.js", line 153, in _emitOnObject
    listener.apply(targetObj, params);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/collusion/lib/main.js", line 98, in null
    if (!privateBrowsing.isActive) {
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/util/deprecate.js", line 23, in deprecated
    deprecateUsage(msg);
    File "resource://jid1-f9uj2thwoam5gq-at-jetpack/addon-sdk/lib/sdk/util/deprecate.js", line 16, in deprecateUsage
    let stack = get().slice(2);
    "]
  3.  
    Does this happen with your other extensions disabled?

    If so, can you restart Firefox and provide a Debug ID for a save attempt where this happens, with other extensions disabled?
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013
     
    I disabled all other extensions and the error still occurred. Here is the Debug ID: D63529250

    Thank you.
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013 edited
     
    the bizarre thing is that it was working just fine earlier yesterday and then bam...no more. Any suggestions?

    EDIT: Maybe I should uninstall the zotero extension and then reinstall it. Given that I've already synced my account the zotero server should have all of my current citations right?
    • CommentAuthoradamsmith
    • CommentTimeApr 5th 2013
     
    There seems to be a problem with Pubmed's API (specifically the efetch funtionality). This is not a Zotero issue and I'd hope it goes away soon - I have tweeted at them, not sure what the best way to contact pubmed is.
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013
     
    Adam, that problem that you are talking about with pubmed may be specific to another issue, not mine because I tried to install zotero on another computer using the firefox extension and I was able to use it just fine with pubmed. Quickly imported from Pubmed into zotero no problem even after syncing with my account. However, I still have problem that is the topic of this thread and would love some progress on it. I cannot use the other computer for anything else but testing.
  4.  
    This doesn't work for me either. The URL in your error report is returning an error. This isn't an issue with your computer.
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013
     
    Dan, are you saying that you are having a similar problem. If so, this might help. I just fixed it...I think. I uninstalled the zotero extension and the Zotero Word for Windows Integration. After both were removed, I restarted firefox and reinstalled both and restarted firefox again. Then I tried to go to that same pubmed link and it worked. I know it is the old "IT Crowd" shut-it-off-and-turn-it-back-on-again technique but it did the trick. I just hope I don't have to keep doing this from time to time because I have a lot more citations to bring in.
  5.  
    You're going to have to take our word here that, when we say the problem isn't on your computer, it isn't. Using command-line tools completely unrelated to Firefox, Zotero, Word, Windows, etc., we can tell that the URL in your error report that Zotero has to download for this to work is returning an error. Specifically:

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    This is a problem on the PubMed servers. They're intermittently returning results, which is why you've seen it work, but nothing you do on your computer will affect whether it works, and you're wasting your time by trying to fix it yourself. Until it's resolved, the only thing you can do is try to click the button again and hope that the request goes through.
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013
     
    But, Dan, how can that explanation account for the fact that Zotero was not accepting citations from any source, irrespective of what website or database that I used? Anyway, so far it is working again and I will certainly take your advise and simply wait it out if it does the same thing again or use an alternate source for the same citation. Thank you again for your effort in the matter.
    • CommentAuthoradamsmith
    • CommentTimeApr 5th 2013
     
    If it doesn't work for another site than pubmed we need a URL for that.
    • CommentAuthorzotnoob
    • CommentTimeApr 5th 2013
     
    Well initially I was following Dan's recommendation that I just put one url even if zotero wasn't working irrespective of the site that I tried. But now that it is working again, I would not able to reproduce the error. :-/
  6.  
    If you have the problem again with other sites, let us know, and we can debug it then.
    • CommentAuthorzotnoob
    • CommentTimeApr 6th 2013
     
    Thank you Dan, will do.

Zotero Forums are powered by Vanilla 1.1.5a