Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthordmichon
    • CommentTimeApr 22nd 2008
     
    Dear All,

    I am using Endnote version 9, and I have their toolbar installed on my computer. When I try to install the Word toolbar plugin for Zotero, it gives an error that reads:
    "Error opening file for writing:
    C:\programfiles\Endnote 9\Zotero.dot

    Click to abort or retry or ignore this file"

    If I ignore, it doesn't install the Zotero toolbar in Word.

    Any ideas? Do I have to uninstall Endnote 9 to get this to work?

    Thanks,

    Dan
    •  
      CommentAuthorRintze
    • CommentTimeApr 22nd 2008 edited
     
    Have you tried installing the Zotero plugin with Word and Endnote closed?
    • CommentAuthordmichon
    • CommentTimeApr 22nd 2008
     
    Hi Rintze,

    Yes I have, and it still gives me the same message.

    I am thinking that I have to uninstall my Endnote 9 toolbar? I kind of don't want to do that just in case Zotero doesn't work for me, I am afraid I will spend another few hours getting the Endnote 9 toolbar back. I also worry that I wrote my dissertation in Endnote, and if I delete that toolbar and I have to get into the notes etc, that I will be in trouble.

    Thanks for the response, any other ideas?

    Dan
  1.  
    What exactly is giving you that error? The Zotero Word Plugin installer? Word itself? Anything that's trying to locate Zotero.dot in the EndNote program directory is terribly confused.

    You might want to try the manual installation instructions.
    •  
      CommentAuthorRintze
    • CommentTimeApr 23rd 2008 edited
     
    Anything that's trying to locate Zotero.dot in the EndNote program directory is terribly confused.

    Except when Endnote has set the startup directory of Word to "C:\programfiles\Endnote 9\".

    dmichon, could you look up the startup folder for Microsoft Word? The manual installation instructions tell you how to find it. If we also know which program is giving the error, we might be able to find out what's going wrong.
    • CommentAuthordmichon
    • CommentTimeApr 26th 2008
     
    Hi Rintze and Dan,

    Thanks so much for your help. I am almost there.

    So, you are right, Rintze, my startup folder in Word is set to "C:\programfiles\Endnote 9\". When I drop the Zotero.dot in that folder, I still get an error -- but now it is a different error -- It tells me that "Word cannot open Zotero.dot."

    So, I tried a few things. First, I took out the EN9CWYW startup doc (it puts the Endnote toolbar up and allows Endnote to function properly) and replaced it with Zotero.dot. When I did this, the Endnote toolbar did not show up (excellent!), but it still gave me an error for Zotero.dot.

    Then I created a new Zotero folder in programfiles, and in that I put the Zotero.dot file, I think switched my Word default for startup to the newly created Zotero folder, but I still got the same error.

    Let me play with it a bit more. When I open Word with the Zotero.dot file on my desktop, it works just fine. Now I have to figure out where to put that file. It doesn't work in the Endnote startup file.

    I will play a bit more and see what happens.

    One more note: I have two logins to this computer (it is mine, but it is on the network at the college I work on). The login which gives me full access to reconfigure anything, Zotero works just fine, it is in the login where my access is restricted where I am having trouble. The college demands that I use the limited access login almost always -- since it is a laptop they have given me the password etc so I can reconfigure.

    Anyway, I will play a bit more, perhaps I can get this to work.

    But thanks for all your advice.

    I will also be posting some comments on some fixes, the biggest for me is the "output" font, that is, Zotero always changes the font in my notes when it updates, and since I work in South Asia and use diacritics, it makes many of the letters boxes etc. Now, that is solved by doing select all and changing the font back to Times Ext Roman (the font with diacritics), but then I have to do that every time I change a footnote.

    Aslo, when generating a report from notes I take, it prints under each not the tags, this just takes up tons of space, if there was a way to generate a report without the tags printing below each note, that would be great.

    Finally, when searching tags, all the notes for a particular book show and the tagged note is highlighted. I see a problem here -- as an academic, I might have 200 notes for a single book, if a particular tag shows up in 10 books, I might have to scroll through thousands of unhighlighted entries to find the highlighted ones. It would be great to have a search for tags in which ONLY the notes in which the tag appears displays, then you can see the complete list all at once.

    Anyway, I will write these up properly and post them elsewhere.

    I see that Zotero could be far better than Endnote, it already is in many ways, but there still a few things, like the above, that concern me before I make the big switch.

    But, thanks again, this is great.

    Take care,

    Dan
  2.  
    Then I created a new Zotero folder in programfiles, and in that I put the Zotero.dot file, I think switched my Word default for startup to the newly created Zotero folder, but I still got the same error.

    Again, please follow the manual installation instructions, and then set the Word startup folder to the Startup folder described there. The Program Files directory is not the correct place for these templates, and a non-admin user could easily not have sufficient access to folders under that directory (e.g., if it needs to write a temporary file).
    • CommentAuthordmichon
    • CommentTimeApr 27th 2008
     
    Thanks so much Dan,

    That worked. It also helped me understand how the startup file works, so I can switch back and forth between Endnote and Zotero now. I am pretty committed to going with Zotero, but I have to really test it before making the big switch.

    Thanks so much.

    And, for suggestions on ways to improve Zotero, where would I post those? As I wrote in my last email, the biggest issue is getting Zotero to NOT change my font in my notes from Times Extension (a Unicode compliant font which allows me to use diacritcs) to Times New Roman (which then puts in boxes and weird symbols).

    Take care,

    Dan
    • CommentAuthordmichon
    • CommentTimeApr 27th 2008
     
    Hi Dan and Rintze,

    Ignore my last request, I found the forum under which I can propose new features.

    Take care,

    Dan

Zotero Forums are powered by Vanilla 1.1.5a