Word 2007 Plugins and Macro

I installed the plugin for Word 2007. At first I have to change the macro setting and save the file to another name because zotero.dot is installed as read-only. After I remove zotero.dot and replaced it with the new one, I can see the Add-Ins tabe showed up. However, when I clicked on any of the button trying to add/edit citations, I still got the macro security setting dialog box. I have tried to save the zotero.dot to zotero.dotm and also the edited document to .dotm (macro-enabled document) but none of that helps. How can I set macro security properly so that I can use plugin for Word 2007. Thanks.
  • For my installation of Word 2007, with the security level set to "Disable all macros with notification", I don't get any notifications regarding the use of the macro. Are you sure you have installed the plugin in the correct folder (the location of the plugin can have an effect on the macro security warnings)? Perhaps you can perform the installation by hand:

    1. In Word 2007, click the Microsoft Office Button, and then click Word Options.
    2. Click Advanced.
    3. Under General, click File Locations. A Startup folder should be listed here. Open this folder in Windows.
    4. Close Word and place the extracted plugin (the zotero.dot file) in this folder, then restart Word.

    You might want to remove any other copies of the plugin before doing all this.
  • I believe I have checked those but I tried it anyway. Unfortunately still no go. Here is what I just did.
    1. check the path under Word Options -> Advanced ->File Locations (C:\Documents and Settings\myid\Application Data\Microsoft\Word\STARTUP)
    2. close word 2007
    3. remove zotero.dot (the only file in that folder)
    4. install zotero plugin
    5. restart Word.

    Did I miss anything? Where can I find other copies of zotero?
    I am surprised that I seem to be the only one who has this problem.
  • Maybe the reply by Tjowens may be of help:


    Create a new document in Word, lower your macro security level to "Disable all macros with notification" and save the document. Then test the plugin buttons.
  • Still doesn't work on my system after trying all the suggestions. There must be something wrong with my system although it was freshly installed a last week.
  • @unplug
    Your solution worked on:
    --Word 2007
    --microsoft Office 2007
    Feel free to ask for other specs (like lspci stuff only under MS Windows).

  • Everything was working fine until today, when the add-in button just disappeared and I cannot use the plugins any more. I am using Word2007 and the formats docx and doc for the same documents (I am working with the same document at work, where I can only use the doc format and at home, where I prefer the docx and I dont know whether it's relevant but I sync the version through Mesh). At home, the plugins just disappeared and Word keeps on warning me about macro everytime I try to run zotero.dot. I tried to install the plugins again but it was of no help. Any clue?
  • Well, found the problem, the Word simply disabled the plugin after a crash. For ppl with the same problem, just need to enable it in the Adds-in button.
  • In regards to the instructions to "place the extracted plugin (the zotero.dot file) in this folder" - how do I access the extracted plugin (the zoter.dot file)? Where does firefox place this extracted plugin (it just installs it)?
  • CSUEval: This is a very old thread and doesn't apply to current versions. See the troubleshooting page and start a new thread if you're still having problems.
This discussion has been closed.