Upgraded to Ubuntu 12.10 -- LibreOffice plug-in no longer works

I upgraded from 12.04 to 12.10 and I am no longer able to add/edit citations in Libre Office in either Standalone or Zotero in Firefox. Tried to reinstall the plug-in in FF several times, kept getting an error. Error report # 1647568582

Thanks for looking into this.
  • I have the same problem; I have tried the instructions on the installation error page to no avail.

    I already had the plug-in installed before the update to 12.10, but today when I tried pressing any of the buttons for add citation or edit citation nothing happens.

    After following the instructions above without improvement, I tried completely removing the add-on in Firefox, the extension in LibreOffice, completely removing everything libreoffice-related in synaptic, restarted computer, reinstall everything and this time the addon appeared in libreoffice with the name 'addon 1' and a huge toolbar where all the buttons were full-text descriptions of their function (instead of the icons they are supposed to be). Attempts to reinstall the addon meet with the same error as first time around.

    Here's a report ID (one of many): 373932349
  • Hi all,

    Same problem as above after an upgrade to Ubuntu 12.10. Have tried uninstalling/reinstalling plugin, manually reinstalling plugin, starting/restarting LibreOffice, and starting restarting computer, etc. No dice.

    Ubuntu 12.10, Firefox 16.0.1, Zotero 3.0.8.

    Thanks much.
  • For a prior version of Ubuntu this was specific to the LO version packaged with Ubuntu and not the vanilla one from LO itself. Probably worth trying that out.
  • Thank you for your response; that does indeed seem to be the problem.

    After removing LibreOffice + related packages through synaptic I installed it manually and everything is working again.
  • edited October 21, 2012
    a less brute force solution is suggested here:
    I haven't tested this, but worth a try before going through the de-install/install process.
  • Solved!

    Thanks adamsmith for the tip about the gentler method for getting the LO plugin to work. I went to Options in LO and indicated which Java version for Zotero to use. I then reinstalled the LO extension successfully and it seems to be working now.

    Thanks to all!

Sign In or Register to comment.