communication problem open office - zotero

Dear all,

Open Office ( 3.2.1 OOO320m19 (Build:9505) ooo-build, Debian package 1:3.2.1-11+squeeze6) and zotero (3.0.8, iceweasel plugin) have been updated recently to the latest version. Since the update, I get the following error when trying to insert a reference in the OO document:

[Exception... "'An error occurred communicating with Zotero:
java.lang.IllegalStateException: Internal error: constructor for java.util.ArrayList has mismatch: 1 parameters; 0 sets of annotations
at com.fasterxml.jackson.databind.introspect.AnnotatedClass._constructConstructor(
at com.fasterxml.jackson.databind.introspect.AnnotatedClass.resolveCreators(
at com.fasterxml.jackson.databind.introspect.AnnotatedClass.getConstructors(
at com.fasterxml.jackson.databind.introspect.POJOPropertiesCollector._addCreators(
at com.fasterxml.jackson.databind.introspect.POJOPropertiesCollector.collect(
at com.fasterxml.jackson.databind.introspect.BasicClassIntrospector.collectProperties(
at com.fasterxml.jackson.databind.introspect.BasicClassIntrospector.forDeserialization(
at com.fasterxml.jackson.databind.introspect.BasicClassIntrospector.forDeserialization(
at com.fasterxml.jackson.databind.DeserializationConfig.introspect(
at com.fasterxml.jackson.databind.deser.DeserializerCache._createDeserializer(
at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(
at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(
at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(
at com.fasterxml.jackson.databind.DeserializationContext.findRootValueDeserializer(
at com.fasterxml.jackson.databind.ObjectMapper._findRootDeserializer(
at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(
at com.fasterxml.jackson.databind.ObjectMapper.readValue(
' when calling method: [zoteroIntegrationApplication::getActiveDocument]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: chrome://zotero/content/xpcom/integration.js :: _callIntegration :: line 273" data: no]

I am running debian stable (2.6.32-5-686).

Any suggestions are welcome!

  • I doubt that Simon will be willing to troubleshoot with Ooo 3.2x - if at all possible, could you upgrade to - ideally - Libre Office or at least the most recent - 3.4 - Ooo version?
  • edited July 6, 2012
    It looks like you're using the gcj JRE, which is old and slow, apparently lacks support for Java 1.5 features, and has been largely supplanted by OpenJDK. Install openjdk-6-jre and either uninstall gcj-jre or configure your system to use OpenJDK using update-java-alternatives.
  • Hi adamsmith and Simon,
    Thanks for your suggesstions. I de-installed open office and installed LibreOffice 3.4.6 (Build:602), with the latest integration plugin (3.5.3). Also I de-installed gcj JRE and installed openjdk-6-jre. Unfortunately, this didn't work, and the zotero panel did not even appear in the libre office toolbar. I also (unsuccessfully) tried de-installing openjdk-6-jre and using sun java instead. Any ideas?
  • First, make sure your JRE shows up in LibreOffice options->LibreOffice->Java. If it does, try removing Zotero LibreOffice Integration from Tools->Extension Manager and reinstalling it from the Zotero preferences.
  • Awesome, this worked. Thank you so much!
This discussion has been closed.